Mouse stutter/lag on F39 with wired mouse

Greetings,

Over the past 2 weeks or so, I’ve noticed my mouse will be a bit laggy when moving it around, it’ll have like a mouse trail and feel like the mouse icon fps is droping when I move it around sometimes. I don’t use my system under any heavy load, this is just when browsing on Firefox for explain, and It didn’t used to do this before. My mouse is a Logitec G203 mouse I’ve had for years, never any issue before. This happens, with gnome extensions off as well, so I know it’s not my extensions that are the problem.

To test, I’ve booted up in Ubuntu as well, with no mouse stutter/lag issue, so I’m wondering what recent updates to Fedora that I could track down that might be causing this. I haven’t seen this reported anywhere else, so I’m afraid that no fix for me is on the horizon unless I can track it down to mutter, gnome-shell, or my nvidia drivers, all of which have had an update in the past 2 weeks or so, so I believe I can safely assume a certain update is the likely culprit.

Has anyone else been experiencing any mouse issues, even though the mouse is wired and plugged in? I’ve tried other ports on my laptop and it still will stutter and the frequency of the stutter is very frequent, i.e. constantly, that I’m considering wiping it for something else in the mean time, it is unfortunately driving me a bit bonkers.

Any help/ideas would be greatly appreciated, thank you.

System specs in a nutshell, Acer Aspire e5-576g laptop, 16BG ram, Wayland, using nvidia drivers 545.29.06 from rpmfusion on an MX150 graphics card with Intel UHD Graphics 620 (KBL GT2), aka hybrid setup.

Below is my system info:

scott@fedora:~$ inxi -Fxxxza --no-host
System:
  Kernel: 6.6.11-200.fc39.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.40-13.fc39 clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=(hd0,gpt2)/vmlinuz-6.6.11-200.fc39.x86_64
    root=UUID=b5474960-c05d-4623-ac63-6f8e8d132a9a ro rootflags=subvol=root
    nvidia-drm.modeset=1
    rd.luks.uuid=luks-91f54db2-736d-4f0c-9c16-b44bc4b7a484 rhgb quiet
    nvidia-drm.modeset=1 rd.driver.blacklist=nouveau
    modprobe.blacklist=nouveau
  Desktop: GNOME v: 45.3 tk: GTK v: 3.24.39 wm: gnome-shell dm: GDM
    v: 45.0.1 Distro: Fedora release 39 (Thirty Nine)
Machine:
  Type: Laptop System: Acer product: Aspire E5-576G v: V1.32
    serial: <superuser required>
  Mobo: KBL model: Ironman_SK v: V1.32 serial: <superuser required>
    UEFI: Insyde v: 1.32 date: 10/24/2017
Battery:
  ID-1: BAT1 charge: 5.5 Wh (100.0%) condition: 5.5/62.2 Wh (8.9%) volts: 12.6
    min: 11.1 model: PANASONIC AS16B5J type: Li-ion serial: <filter>
    status: full
CPU:
  Info: model: Intel Core i5-8250U bits: 64 type: MT MCP arch: Coffee Lake
    gen: core 8 level: v3 note: check built: 2017 process: Intel 14nm family: 6
    model-id: 0x8E (142) stepping: 0xA (10) microcode: 0xF4
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 3398 high: 3401 min/max: 400/3400 scaling:
    driver: intel_pstate governor: powersave cores: 1: 3383 2: 3401 3: 3400
    4: 3400 5: 3400 6: 3400 7: 3400 8: 3400 bogomips: 28800
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: gather_data_sampling mitigation: Microcode
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
    vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: IBRS
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, STIBP: conditional,
    RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel UHD Graphics 620 vendor: Acer Incorporated ALI driver: i915
    v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports:
    active: eDP-1 empty: DP-1,HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:5917
    class-ID: 0300
  Device-2: NVIDIA GP108M [GeForce MX150] vendor: Acer Incorporated ALI
    driver: nvidia v: 545.29.06 alternate: nouveau,nvidia_drm non-free: 545.xx+
    status: current (as of 2023-10; EOL~2026-12-xx) arch: Maxwell code: GMxxx
    process: TSMC 28nm built: 2014-2019 pcie: gen: 1 speed: 2.5 GT/s lanes: 4
    link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.0 chip-ID: 10de:1d10
    class-ID: 0302
  Device-3: Chicony [] driver: uvcvideo type: USB rev: 2.0 speed: 480 Mb/s
    lanes: 1 mode: 2.0 bus-ID: 1-7:4 chip-ID: 04f2:b571 class-ID: 0e02
  Display: wayland server: X.org v: 1.20.14 with: Xwayland v: 23.2.4
    compositor: gnome-shell driver: X: loaded: modesetting,nvidia
    unloaded: fbdev,nouveau,vesa alternate: nv dri: iris gpu: i915
    display-ID: 0
  Monitor-1: eDP-1 model: Najing CEC Panda LM156LF1L03 built: 2017
    res: 1920x1080 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64")
    diag: 395mm (15.5") ratio: 16:9 modes: 1920x1080
  API: OpenGL v: 4.6 vendor: intel mesa v: 23.3.3 glx-v: 1.4 es-v: 3.2
    direct-render: yes renderer: Mesa Intel UHD Graphics 620 (KBL GT2)
    device-ID: 8086:5917 memory: 15.13 GiB unified: yes display-ID: :0.0
  API: EGL Message: EGL data requires eglinfo. Check --recommends.
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Acer Incorporated ALI
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl, snd_soc_avs,
    snd_sof_pci_intel_skl bus-ID: 00:1f.3 chip-ID: 8086:9d71 class-ID: 0403
  API: ALSA v: k6.6.11-200.fc39.x86_64 status: kernel-api
    tools: alsactl,alsamixer,amixer
  Server-1: PipeWire v: 1.0.1 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0
    chip-ID: 8086:24fb class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Acer Incorporated ALI driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 04:00.1 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp4s0f1 state: down mac: <filter>
Bluetooth:
  Device-1: Intel Wireless-AC 3168 Bluetooth driver: btusb v: 0.8 type: USB
    rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-5:3 chip-ID: 8087:0aa7
    class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 2 state: up address: <filter> bt-v: 4.2
    lmp-v: 8 status: discoverable: no pairing: no class-ID: 6c010c
Drives:
  Local Storage: total: 238.47 GiB used: 177.07 GiB (74.2%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: SK Hynix model: HFS256G39TND-N210A
    size: 238.47 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 1P10 scheme: GPT
Partition:
  ID-1: / raw-size: 236.87 GiB size: 236.87 GiB (100.00%)
    used: 176.75 GiB (74.6%) fs: btrfs dev: /dev/dm-0 maj-min: 253:0
    mapped: luks-91f54db2-736d-4f0c-9c16-b44bc4b7a484
  ID-2: /boot raw-size: 1024 MiB size: 973.4 MiB (95.06%)
    used: 307 MiB (31.5%) fs: ext4 dev: /dev/sda2 maj-min: 8:2
  ID-3: /boot/efi raw-size: 600 MiB size: 598.8 MiB (99.80%)
    used: 17.4 MiB (2.9%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-4: /home raw-size: 236.87 GiB size: 236.87 GiB (100.00%)
    used: 176.75 GiB (74.6%) fs: btrfs dev: /dev/dm-0 maj-min: 253:0
    mapped: luks-91f54db2-736d-4f0c-9c16-b44bc4b7a484
Swap:
  Kernel: swappiness: 0 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) priority: 100
    comp: lzo-rle avail: lzo,lz4,lz4hc,842,zstd max-streams: 8 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 54.0 C pch: 45.5 C mobo: N/A
  Fan Speeds (rpm): N/A
Info:
  Processes: 331 Uptime: 14m wakeups: 0 Memory: total: 16 GiB
  available: 15.49 GiB used: 4.46 GiB (28.8%) Init: systemd v: 254
  target: graphical (5) default: graphical tool: systemctl Compilers:
  gcc: 13.2.1 Packages: pm: rpm pkgs: N/A note: see --rpm
  tools: dnf,gnome-software,yum pm: flatpak pkgs: 118 Shell: Bash v: 5.2.21
  running-in: kgx inxi: 3.3.31

Hello,

for a few weeks I have been having a similar problem now. I use a Thinkpad P52 (nvidia quadro p3200). When I only use the internal display, the mouse, trackpoint or touchpad is extremely laggy. However, this only occurs under Wayland and not under X11. Strangely enough, the problem does not occur when I connect a second display via Thunderbolt.
To summarize, I have tried the following combinations:

  • internal display, Wayland, nvidia (negativo17) → mouse or whatever not usable
  • internal display, Wayland, WITHOUT nvidia (akmod module was initially not built with Linux 6.7) → everything ok
  • internal display, X11, nvidia → everything ok
  • internal display + external display (via Thunderbolt 3), Wayland/X11, nvidia → everything ok

If any log file might be helpful, please let me know. I can’t find anything interesting in journalctl nor dmesg.

A new mutter/gnome-shell update should be out in the next week or two, so let’s see how that goes. For now I don’t think there is much else we can do but wait and see until then.

I suspect that may be influenced by the fact that the nvidia drivers were installed from negativo17.

The drivers from negativo are not tweaked, tested, and verified the same as are the ones installed from rpmfusion. I have noted some users that have no problems and others that have multiple issue with drivers installed from a source other than rpmfusion

I always recommend removing the drivers installed from some other source and replace them with the drivers installed from rpmfusion.

Are you using GNOME shell? If yes, have you tried disabling all extensions and restarting gnome shell (logout + login)? At least some time ago extensions could cause this misbehaviour.

@computersavvy While that might be a cause for some users, I installed my NVIDIA drivers from rpmfusion and have the mouse stutter lag, so I don’t think the negativo17 drivers are the sole culprit here.

@genodeftest yes, i’ve tried and tested with extensions all off and the stutter lag still happens unfortunately. I did not have this stutter lag, until the last gnome-shell/mutter updates from one month ago, which was also about the time nvidia drivers from rpmfusion were updated as well, so it’s one of these that I believe are causing the issue. I’m sure more users are affected, they probably just haven’t picked up or noticed as much.

Thanks for all the comments!

@computersavvy As Scotty Trees said the problem probably also occurs with the rpmfusion driver, but for the sake of completeness I will also try them. By the way, I don’t think the drivers from negativo17 are not tweaked. At least they also included the workaround for linux 6.7 and there are reports of people that had less problems with the drivers from negativo17 compared to rpmfusion.

@genodeftest Yes, I’m also use the Gnome shell, but I don’t use any extensions. So, that’s not the reason for the problem.

Basically, I think it’s probably a problem in the interaction between mutter/Gnome shell, wayland and the Nvidia driver - as so often in last few years… Let’s wait for the upcoming mutter/Gnome shell updates.

1 Like

I take it all back and say the opposite. I have now installed and removed the negativo17 and rpmfusion drivers several times (because I couldn’t really believe it and a kernel update was installed in between). The problem does not occur with the rpmfusion drivers. I will send a bug report to negativo17.