Noise Cancelling Bluetooth headset microphone is extremelly sensitive on Fedora

I’m using Fedora 33 and I have a Sennheiser PXC 550ii (active noise cancellation) and the microphone works really bad, is extremely sensitive and the other people can hear everything, in pavucontrol for example I can see that microphone bar moves a lot with any slight sound. Instead of a USB headset for example, the bar move almost nothing. Is like all the headset mics are working to receive sound not cancelling.

I tried set up pulseaudio echo cancel but looks like not work for bluetooth devices.

In android works fine.
Thanks for any help.

If you refer to zoom, there you can make adjustments in the settings too.

The same happen with MS Teams (the option to adjust the mic sensitivity not works), Skype and Zoom.



Can you confirm that the firmware is up to date from the Headphone?
From tomorrow on F35 should be available as beta. You could check if it works with it (Live ISO). Pipewire is there the default. I solved my audio problems moving from F32 to F34.

For F33 ends the support in few weeks anyway.

I’ve updated to F34 and now the headphones works fine in all the apps, even when I connect the headphones using blueetooth using blueman applet, now show all the compatible profiles previously was just A2DP and HSPF.