No Sound

I’ve just installed Fedora-39 on a new disk and have started encountering the usual problems with sound and vision. Embedded videos didn’t work, unfortunately i couldn’t find my notes from the last time, so I tried a few things and eventually got it to work.

  • Now I’ve lost all sound.
  • The icon does not appear in the top-panel right-hand dock.
  • Settings>Sound shows Output-Output Device-No Output Devices
  • Settings>Sound shows Input-Input Device-No Input Devices

Presumably my fiddling has removed something essential. What do I need to do to sort this out?

Well that’s obvious! You just need to undo what you did. :slightly_smiling_face:

The history command can be useful if you did things from the command line. Better yet, if you took a snapshot of your root file system (before you began fiddling), you could use that as a restore point to undo whatever you’ve done.

1 Like

Well that’s got to be the quickest and easiest answer to a forum question I’ve had. I’d not heard of “history”, but I will remember it in future, as “Those that fail to learn from history are doomed to repeat it!

Using “history” I saw that I had already tried to backtrack all my commands, but one had failed. I’ve now tried again without parameters and it works:

sudo dnf install pipewire-pulseaudio