No sound after 'sudo dnf update' today

Hello all.

I’m on a fresh install of F30 (my first time using Fedora) and after running ‘sudo dnf update’ this afternoon I don’t have any sound.

My motherboard has a Soundblaster Recon3di onboard. Checking dmesg originally showed that there was no (longer?) any firmware for this device in /lib/firmware which I have rectified and now dmesg shows the device correctly.

[ 3.699030] snd_hda_intel 0000:00:1b.0: enabling device (0000 → 0002)
[ 3.699485] snd_hda_intel 0000:01:00.1: enabling device (0000 → 0002)
[ 3.699518] snd_hda_intel 0000:01:00.1: Disabling MSI
[ 3.699521] snd_hda_intel 0000:01:00.1: Handle vga_switcheroo audio client
[ 3.724617] snd_hda_codec_ca0132 hdaudioC0D2: autoconfig for Recon3Di: line_outs=3 (0xb/0x11/0x10/0x0/0x0) type:line
[ 3.724619] snd_hda_codec_ca0132 hdaudioC0D2: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[ 3.724620] snd_hda_codec_ca0132 hdaudioC0D2: hp_outs=1 (0xf/0x0/0x0/0x0/0x0)
[ 3.724620] snd_hda_codec_ca0132 hdaudioC0D2: mono: mono_out=0x0
[ 3.724621] snd_hda_codec_ca0132 hdaudioC0D2: dig-out=0xc/0xd
[ 3.724622] snd_hda_codec_ca0132 hdaudioC0D2: inputs:
[ 3.724623] snd_hda_codec_ca0132 hdaudioC0D2: Mic=0x12
[ 3.724623] snd_hda_codec_ca0132 hdaudioC0D2: Line=0x13
[ 5.671288] snd_hda_codec_ca0132 hdaudioC0D2: ca0132 DSP downloaded and running

I’m pretty sure I’m using PulseAudio (ps aux | grep pulseaudio) but I can also grep for alsa and get a result so I’m not 100% sure. I can and have run alsamixer and fiddled around a bit with no success.

I’ve done a few random things from here: How to troubleshoot sound problems - Fedora Project Wiki and here:

While I’m not completely new to Linux in general, I’m new to Linux as a desktop OS. I’m trying to make this post as helpful and informative as possible but I’ll probably miss something. I’ll do my best to follow steps and advice :slight_smile:

Was sound working before the update?

Hello. Yeah, It was.

Assuming that was your most recent upgrade, can you run sudo dnf history info and post the results here, please? If it wasn’t your most recent upgrade, you can run sudo dnf history which will show you the history of all dnf transactions, identify the one that affected you and then do a sudo dnf history info <transaction_id>

I’m going to chalk this one up to user issue. Things on Fedora work slightly differently to what I’ve been used to (Ubuntu) and I think I messed up the update which broke sound plus a few other bits of software.

I came to this conclusion by getting frustrated, reinstalling Ubuntu, remembering why I didn’t want to use Ubuntu anymore, reinstalling Fedora and paying attention to the update which I allowed to work properly.

Basically, PEBKAC :slight_smile:

This post was written while listening to The Joshua Tree.

I’ve been running Fedora 30 on a Dell XPS 8970 with ‘Digital Stereo (HDMI) Output’ since September 2019. I did a dnf update a few weeks ago, and afterwards, my sound no longer worked. Same thing happened right around Christmas (2019), but a later update fixed it. I just did another update today (5.6.11-100.fc30.x86_64 #1 SMP Wed May 6 20:30:51 UTC 2020 x86_64) and it’s still broken.

I think last time it was something overlooked with audio through HDMI…

Hello, I’ve found out that if you do the dnf update when logged in it kills the sound but if you open the terminal before the login so when your logged out by pressing ctrl alt f2 then do $ sudo dnf update you don’t loose the sound, Hope this helps

We are currently running fedora 34 & 35 and this post was about fedora 30 which used pulseaudio while the current fedora uses pipewire. It is not likely that your fix was applicable to the topic from 2 years ago.

Please only post to relevant topics and refrain from reopening such old threads.

However, I would welcome you to the fedora community and invite you to continue to participate in the future.