No network after update

Just updated a little while ago for F38 on my laptop and I’m no longer able to establish a network connection via ethernet or wifi. My phone has no connection issues.

Should I just do a fresh reinstall?

Hi Jasey,

I had this issue as well sometimes ago and my solution was to enter the following to the terminal:
sudo systemctl restart systemd-resolved
sudo ausearch -c ‘systemd-resolve’ --raw | audit2allow -M my-systemdresolve
sudo semodule -i my-systemdresolve.pp

Hope this solves your issue as well. Good luck.

Ok that’s really strange. I had it on sleep then logged in and suddenly it’s connected. Strange because I tried rebooting earlier and the issue persisted.

Thanks for the tip @stippi. I’ll refer back to your post if I have issues again.

It happened again. I tried your solution but the second command returned ‘Nothing to do’.

Tried putting my laptop to sleep a couple times but no connection working.

Fedora 37 wifi card not detected - #2 by vgaetera

Ok restarting the router allowed both devices to be connected. Whew.