Connected to wifi but no Internet v2

Dear community,
unfortunately i ran into the exact same issue as this guy:

(solution: perform an update) → My Problem: I can not do it the same way he did (see below)

After some reboots my internet connection suddenly stopped working on my IdeaPad 5 Pro 14ACN6 / Fedora 38 (Budgie). It is not a hardware problem. Running a live USB with F38 works perfectly fine. So do other computers in the same network. I tried different Wifi networks, all show the ‘connected to Wifi’ symbol without any further notes/hints. In Software Manager → Updates is listed, that it is/was/wanted to downloading/download a system update (looks like it did not finish (or even start (?), maybe i interrupted).

Regarding the mentioned discussion (solution) above: I do not have a VPN installed that is able to circumvent the issue. I have Proton VPN installed, even with alternative routing activated it does not work. However running Tor browser works perfectly fine. It does not help me with the `update is the solution’ problem, when i can not perform an update due to missing (working) internet connection. Other solutions mentioned in the article above I already tried without success.

Does anyone of you guys have a solution for this problem?

Thank you in advance guys, lets hope my english worked to describe the Issue :))

~ Kolibri

Sounds like a DNS related issue, try using a public DNS.
If the issue persists, collect the diagnostics:

resolvectl --no-pager status; resolvectl query
tracepath -4nm10; tracepath -6nm10
1 Like

I did change the DNS and tried differend puplic DNS:

Unfortunately the first line of commands did not work, the command is unknown…
Second line had these results:

(Internet is still not working)

sudo tee /etc/resolv.conf << EOF > /dev/null
sudo dnf -y install systemd systemd-resolved
sudo dnf -y reinstall systemd systemd-resolved
sudo systemctl enable systemd-resolved.service
sudo systemctl restart systemd-resolved.service
sudo ln -f -r -s /run/systemd/resolve/stub-resolv.conf /etc/resolv.conf

If there’s an error, disable IPv6 in the connection settings and try again.