No more content in /boot/efi

What a wonderful day.
This morning: my laptop was not able to boot anymore. No more content in /boot/efi.
Booted in rescure mode and after tried unsuccessfully to enable the network, I decided to reinstall Fedora 40. It took me the time it took not to find a solution, to reinstall Fedora 40.

I’ve got absolutely no clue on why the boot content disappeared …

2 Likes

Potentially the efi partition was changed.
Is this system dual booting?
Did you do anything that may have deleted files there?
Is it possible the system was switched from uefi boot to legacy boot in some way?
Was the disappearance because the partition did not mount? was not available? was deleted? was removed from /etc/fstab?

3 Likes

The laptop has no dual boot, only Fedora.
The laptop was running during the night and when I connect to it in the morning, it hanged. Probably due to a broadcom wifi driver problem, or a wayland one:

  • I posted a message some days ago related to problem with this old broadcom chipset I met some days ago.
  • I posted a message too related to a stack trace I found in the system journal, stack trace related to wayland.

So, the laptop rebooted and hanged immediately. After several similar failed boot in a row, I started in secure mode and I saw immediately the problem with the /boot/efi in the boot log.

I tried to find a solution to this problem but because I didn’t had access to the network, I finally decided to reinstall fedora 40.
The /boot/efi directory was empty but I didn’t check if it was empty because there was a mount problem or because the efi partition had a problem.

I checked the smart status of the ssd drive and it was OK (it’s a samsung and it’s less than one yearr old).

I don’t know why fedora insists on mounting /boot/efi on boot, it isn’t used by fedora directly.
/boot/efi only needs to be mounted for efi grub or firmware updates.

1 Like

I think I remember that the /boot/efi error message in the boot log was associated to systemd-boot or something like that.

Added boot, f40, workstation