No display past grub

I am dual-booting Windows 10 and KDE Fedora, recently my PC has been showing a black screen, followed by no display at all after booting an OS, either from Grub (which seems to be working fine) or from the bios.
I tried using a live install USB with Manjaro on it, however, it had seemingly the same problem, it was loading fine until “reached target sound card”, when it had the same problem.

one time while I was attempting to boot fedora I think I saw “grub-core/kern/fs.c unknown filesystem”, however I haven’t been able to get it to show up again

I tried swapping the SSD with my windows and linux installs with a different
one with linux mint XFCE on it, however it had the same issue.

This appears to be a hardware problem, but it is possible that an unsafe shutdown corrupted the filesystem so you now have a double failure.

I have decades of experience with systems that were exposed to vibration and humid “salt” air on research vessels. For PC’s with problems we would reseat all cards and connectors using “contact enhancer” which (due to the number of computers in modern cars) is available from auto parts stores. Any connectors showing “green scum” should be replaced.

I gather that the display works in “BIOS”. Can you get a text console (by editing the grub2 command-line to remove rhgb quiet and add 3 (multi-user target) at the end)? This should give a text console and may allow you to find details of the problem in logs.

If your vendor provides diagnostics in the “BIOS”, you should run those. If not, try running memtest86+ (from the Fedora Live Installer) for an extended period (24 hours).

It could be useful if you can find a probe for your model in the LHDB so we get an overview of the hardware configuration. If you can boot to a text terminal and have another system you can save the output from inxi -Fzxx and paste it (as pre-formatted text using the </> button from the top line of the text entry panel).

my hardware is a custom PC with a R5 3600 CPU, Gigabyte B450M DS3H motherboard, 2X16GB G.Skill Aegis ddr4 3200 CL16, Gigabyte eagle RX 6600 GPU, an old second-hand gigabit ethernet card, 1TB Seagate barracuda HDD, 512GB silicon power A55 SATA SSD, and a 500 GB gigabyte aorus gen4 SSD.

I had win10 installed on the A55 SSD, then later got the Aorus gen4 which I put a fresh win10 install on, I didn’t want to wipe the A55, as I didn’t know whether there were important data hidden in places I wouldn’t notice, so I just deleted everything I knew was safe to delete and was allowed by windows, I had it like that for months without any issues. ~2 weeks ago, I installed Fedora on the Aorus gen4, and it worked fine for a while before the problems started.

also, if this is of any help, when the problem first happened, decided to just wait a day and try again, as that tactic worked for me in the past, after waiting, it did properly boot a couple of times before it broke again, showing the exact same issues.

I don’t see any mention of the the graphics hardware. From TechPowerUp:

This processor does not have integrated graphics, you will need a separate graphics card.

I assume you are using the Gigabyte B450M DS3H onboard graphics. The inxi -Fxzz output has much more detail (but still misses subvendor ID’s) and also shows the drivers being used. This helps us understand the full status of the system, and aids others with similar hardware looking for help using search engines. There should be details of the graphics hardware and driver.

I had a system from 2007 that only had Nvidia graphics. It started to have similar issues with display going black after a day of record high heat. Then it failed entirely with a 3-beep BIOS (Morse code “S”) for no graphics device found.

Without more information there is not much we can do. Booting to the multi-user target? This should give you a text console where you can use inxi and journalctl, but a cheap graphics card might be the easy way to get the system working.