No brightness control in fedora 38 HP laptop

I installed Fedora 38 (fresh and clean install). I found that there is no brightness setting. Functions key of laptop that tweaked brightness does nothing.

Along with this I also observed slow and sluggish performance. Almost cannot see animations + plus videos on youtube keep glitching.

Also along with these two issue I have been facing issue in sleep too. If laptop detect no activity and goes to sleep it does not wake up(screen remains off). I have to force shutdown it to make it work again

It’s first time I am using a Linux distro that is slower than windows.

Are you using GNOME, or some other DE? What laptop is it? What does inxi -bz print out?


  Kernel: 6.2.9-300.fc38.x86_64 arch: x86_64 bits: 64 Desktop: GNOME v: 44.0
    Distro: Fedora release 38 (Thirty Eight)
  Type: Laptop System: HP product: HP Laptop 15g-br0xx v: Type1ProductConfigId
    serial: <superuser required>
  Mobo: HP model: 832A v: 23.70 serial: <superuser required> UEFI: Insyde
    v: F.52 date: 03/04/2019
  ID-1: BAT1 charge: 13.2 Wh (43.6%) condition: 30.3/32.1 Wh (94.3%)
  Info: dual core Intel Core i3-7100U [MT MCP] speed (MHz): avg: 500
    min/max: 400/2400
  Device-1: Intel HD Graphics 620 driver: N/A
  Display: wayland server: X.Org v: 22.1.9 with: Xwayland v: 22.1.9
    compositor: gnome-shell driver: dri: swrast gpu: N/A
    resolution: 1920x1080~60Hz
  API: OpenGL v: 4.5 Mesa 23.0.1 renderer: llvmpipe (LLVM 16.0.0 256 bits)
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169
  Device-2: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi
  Local Storage: total: 931.51 GiB used: 7.99 GiB (0.9%)
  Processes: 658 Uptime: 1h 20m Memory: available: 7.54 GiB
  used: 3.49 GiB (46.3%) Shell: Bash inxi: 3.3.27

I also tried sudo lshw -C display and the result was:

 *-display UNCLAIMED       
       description: VGA compatible controller
       product: HD Graphics 620
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 02
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm vga_controller bus_master cap_list
       configuration: latency=0
       resources: memory:a0000000-a0ffffff memory:90000000-9fffffff ioport:4000(size=64) memory:c0000-dffff
       product: simpledrmdrmfb
       physical id: 3
       logical name: /dev/fb0
       capabilities: fb
       configuration: depth=32 resolution=1920,1080

This looks strange. I do not see the i915 driver loaded for that intel GPU.
Please show us the output of lsmod | grep i915

i915                 3768320  0
drm_buddy              20480  1 i915
drm_display_helper    200704  1 i915
cec                    86016  2 drm_display_helper,i915
ttm                   102400  1 i915
video                  73728  1 i915

also it says Graphics: Software Rendring instead of intel HD Graphics 620

Have you updated Fedora packages and vendor BIOS to current versions? It is hard for others to help if their software doesn’t match what you are using, and it is a waste of time diagnosing problems that were solved with updates.

Can you adjust brightness using the Gnome controls rather than the keyboard controls?

there are no BIOS update for my device. its a low end laptop

did you mean by settings? if yes than there is no option in the settings itself

I think the video line should have an entry of the form <vendor>-wmi. On a Dell system, that line is: video 73728 2 dell_wmi,i915 and modinfo dell_wmi has

description:    Dell laptop WMI hotkeys driver

AFAIK, Lenovo ThinkPads use think_lmi. What does sudo journalctl -b | grep -i wmi show?

Jul 03 01:18:00 fedora kernel: wmi_bus wmi_bus-PNP0C14:01: WQBJ data block query control method not found
Jul 02 19:48:16 fedora kernel: input: HP WMI hotkeys as /devices/virtual/input/input11
Jul 02 19:48:18 fedora systemd-logind[703]: Watching system buttons on /dev/input/event10 (HP WMI hotkeys)

Gnome Brightness is a slider in the box you get by clickiing on the “system menu” at top right of the screen (look for the cursor arrow in the image below):

“WMI” is Windows Management Instrumentation" part of the vendor-specific firmware. You need to find an HP user who has the keyboard working.

I also see kernel: wmi_bus wmi_bus-PNP0C14:02: WQBC data block query control method not found, but HP WMI hotkeys as /devices/virtual/input/input11 is new to me. It might have helped to mention HP in the title of your post so HP users would take notice.

For kernel- 6.3.8-200.fc38.x86_64:

% modinfo hp-wmi
filename:       /lib/modules/6.3.8-200.fc38.x86_64/kernel/drivers/platform/x86/hp/hp-wmi.ko.xz
alias:          wmi:5FB7F034-2C63-45e9-BE91-3D44E2C707E4
alias:          wmi:95F24279-4D7B-4334-9387-ACCDC67EF61C
license:        GPL
description:    HP laptop WMI hotkeys driver
author:         Matthew Garrett <>
depends:        sparse-keymap,wmi,platform_profile,rfkill

yeah i know, it was there untill fedora 37.


i dont think its keyboard issue, because keyboard is working fine for audio. Its not working for brightness because Fedora itself is lacking the capability to control brightness

Brightness control works for me on this iMac, so Fedora 38 does support brightness control as advertised. There are recent efforts to reduce reliance on the many different vendor-specific hacks. For a while I was using ddcutil in a terminal, but now the Gnome control is working.
You can check to see if ddcutil works on your hardware: Brightness Issue Fedora37.

Thnx , kindly also help in executing the script as well (how to run) and I was thinking will the max and min value in script work for my laptop too?

Using command-line tools is often the only way to fix problems in linux. A good place to learn is Linux Command. Not all vendors use the same limits, so you have to check.

You can go to System Setting → Power Management and adjust screen brightness from there.

As mentioned there is no option for altering brightness.
It’s the kernel 6.2 and 6.3 that is causing the issue.

Many linux modules have options to support specific hardware. You can’t blame the kernel if you aren’t using the right options, but without vendor support, it can be hard to find them. For example, some Framework laptops require:

sudo grubby --update-kernel=ALL --args="module_blacklist=hid_sensor_hub"

to enable brightness in recent kernels. Kernel developers can’t test every model laptop. Some manufacturers will make the effort to report issues to liinux developers. If not, then it is up to someone with access to the hardware to figure out and report the required options.