No audio through headphones, only constant popping sounds


I’m using Fedora 30 on an Asus Zenbook UX390U and can’t hear anything through the headphones except a popping sound. The speakers work fine and these same headphones work when I boot the laptop to Windows. Before the restart I fiddled around a bit and fear I may have broken something - at the same time I’m trying to avoid a full reset because I’ve got things setup somewhat already.

The background:

On a fresh install I was having issues with my speakers not changing volumes so I followed the directions here: sound - Volume control on asus zenbook 3 - Ask Ubuntu (essentially changing a few PulseAudio settings through the conf files so the volume changes are respected) - later I noticed my headphone volume wasn’t working - the eventual fix was to edit some similar PulseAudio conf files but before I realized that I did a few things:

  • tried (and failed) to install the PulseAudio preference util called paprefs from source which included installing gtkmm-3.0 gcc and some other development tools
  • installed flash-plugin (unrelated to debugging - I did for another reason - but may be related to the issue)

Since then things I’ve tried to fix:

  • removing the pulseaudio plugin (and since reinstalling it)
  • removing flash
  • reinstalling alsa-utils
  • changing volume through alsamixer
  • checking dmesg for anything interesting (no luck)
  • following the steps here: How to debug sound problems - Fedora Project Wiki including searching for custom model parameters (no luck)

And I’m reaching the end of my rope! Any advice about what could be the problem or any other debug steps to take would be welcome, thank you!

Gnome?? Can you use pavucontrol?

dnf -y install pavucontrol

I personally use XFCE… and here the xfce4-pulseaudio-plugin works great. Is ugly, but you can install nice themes as Yaru or united-gnome from here.

1 Like

Yeah it’s on Gnome and I installed pavucontrol but no luck - everything looks normal there. Now after a sleep/wakeup cycle the audio is working normally again so it’s hard to say further. Would be curious what other debug options there are for future problems though - I seemed to have hit a wall of where to look for understanding the audio handling deeper

@myburger, I may have something for you to check.

I’ve observed similar symptoms (popping sounds, no sound) on my desktop pc when I tried to switch sound between speakers and headphones without uplugging and replugging them every time – but no sound part was desirable to me. I.e. when I want for sound to be from he headphones only I sometimes hear these popping sound from my speakers,

You situation is kind of reversed – you can’t physically unplug your speakers, and your headphones seem to be muted. Still what you have and I observe on my system can be connected.

(1) Thirst thing to check is if unplugging and replugging you headphones doesn’t resolve you problem (it should, I think).

The second thing is open you terminal and run alsamixer. You should see one volume regulator in the center of the screen and card: PulseAudio in the upper-left corner.

Press [F6] to switch to the other sound card. The one you need will have many volume regulators )) mine is called HDA Intel PCH, but exact name depends on sound hardware you have.

Press [right] to scroll through controls available. (2) Actually check these to see if you have your headphones muted or with low volume here. (3) If not – look for the control called Auto-Mute.

It should be Enabled by default. Setting in to disabled on my system ([up] to enabled, [down] to disabled) makes the sound play from both the speakers and the headphones, enables – from headphones only.

Basically, there’s some logic in the alsa sound system that by default plays to speakers, but when it detects headphones plugged in – it mutes the speakers and plays to headphones. All as it should be. In my case I have a faulty headphones jack (from time and much on plugging/unplugging I guess), so I wanted to somehow switch sound without unplugging physical connectors each time.

In your case this logic can be failing for some reason, disabling headphones when it shouldn’t. Please report here, what points (1) and (3) do for you and have you found something useful in (2).

1 Like