Headphone jack not working

I have installed Fedora 36 on my new computer, but I have a problem with my audio. When I plug in my headset, it won’t be detected. It only works via the external soundcard of the headset. No headphones work through the built-in headphone-jack at all. Can someone tell me what I have to check or to change in order to make the system detect devices plugged into the internal soundcard?

Play with the Configuration-tab in pavucontrol-app (upper right), (and turn your volume low, please) to select the correct output that works. Additonally, you may afterwards have to adjust the correct output in pavucontrol’s Output-tab.

Welcome to the forum!

Isn’t pavucontrol for PulseAudio? As far as I know Fedora 36 uses PipeWire by default and I didn’t change anything. Please correct me, if I’m wrong.

1 Like

pavucontrol still works with pipewire. I use it. Pipewire handles the pulseaudio protocol.

So, it detects two devices: “USB Audio Analog Stereo” and “GA104 High Definition Audio Controller Digital Stereo (HDMI 2)”. I don’t think it’s “USB Audio Analog Stereo” and I connected the headphones to the integrated headphone jack of my sound card and not via HDMI or something like that. It seems like PipeWire doesn’t detect the internal headphone jack.

1 Like

Someone created a file here with this command:
sudo touch /etc/modprobe.d/audio-jack.conf

With this content:

options snd_hda_intel model=headset-mode

saved it, and audio jack appears to be working after reboot.


I tried this, but it didn’t work.