New to Fedora on Notebook

Just got a old Dell Vostro 3350 notebook, Fedora 33 is running on it in no time. (It is a default Workstation setup, with only Google Chrome browser installed.)

I am new to using Fedora Workstation on a notebook, my previous experience is manly on a desktop machine.

I notice my first issue: My Notebook Screen do not goto Locking mode after idle even for 30 minutes.

In Gnome Settings-> Power, I have:
Dim Screen When Inactive: On (But my screen did not Dim)
Blank Screen: 5 minutes (But my screen did not Blank)
Automatic Suspend: When on battery <On Battery Power On w/ Delay 20 minutes> (But my notebook did not Suspend)

How to reproduce:
Put notebook in battery power.
Do not close Lip
Reboot into Graphical Target.
Leave it idle for 30 minutes

(I got same result after doing a dnf update and reboot)

Where should I start to look into this problem?

1 Like

Did you change anything in /etc/systemd/logind.conf and are there any programs which inhibit system to report its idle status?


No, not that I am aware of.

I only installed Google-Chrome via Gnome-Software.

Here is my /etc/systemd/logind.conf:


Look for BIOS update. It might also be related to GPU driver. inxi -MGxxxz will output useful info.
Browsers can inhibit those settings and Chrome (by default) snoops around even if you didn’t start it up, try chromium or ungoogled chromium-browser-privacy instead.


Was this happening before installing chrome? Can you try without chrome?


My BIOS is latest as per Dell.

I removed Google-Chrome and see if it helps.

I just done

sudo dnf remove google-chrome*

And waiting to see if it helps.

Same, screen did not blank after removing Chrome.

Is there a display manager installed and running?(gdm)

1 Like

How can I be sure to find out?

It is a default Fedora Workstation installation.

Then it should be installed.

sudo dnf list installed | grep gdm

Will show if it’s installed.

Yes, gdm is there.

$ sudo dnf list installed | grep gdm
gdm.x86_64                                         1:3.38.2-1.fc33                     @updates 

And seems running:

$ sudo ps -aux | grep gdm
earlyoom     687  0.0  0.0   2496  1944 ?        SLs  00:29   0:02 /usr/bin/earlyoom -r 0 -m 4 -M 409600 --prefer ^Web Content$ --avoid ^(dnf|packagekitd|gnome-shell|gnome-session-c|gnome-session-b|lightdm|sddm|sddm-helper|gdm|gdm-wayland-ses|gdm-session-wor|gdm-x-session|Xorg|Xwayland|systemd|systemd-logind|dbus-daemon|dbus-broker|cinnamon|cinnamon-sessio|kwin_x11|kwin_wayland|plasmashell|ksmserver|plasma_session|startplasma-way|xfce4-session|mate-session|marco|lxqt-session|openbox)$
root         941  0.0  0.1 468256  8996 ?        Ssl  00:29   0:00 /usr/sbin/gdm
root        1495  0.0  0.1 634708 13376 ?        Sl   00:29   0:00 gdm-session-worker [pam/gdm-password]
user          1542  0.0  0.0 374056  5936 tty2     Ssl+ 00:29   0:00 /usr/libexec/gdm-wayland-session /usr/bin/gnome-session
root        5330  0.0  0.1 395196 11512 ?        Sl   07:44   0:00 gdm-session-worker [pam/gdm-password]
user          6379  0.0  0.0 221564   848 pts/0    S+   09:57   0:00 grep --color=auto gdm

If, from the command line, you issue the command
systemctl suspend
what happens?

1 Like

I am sorry that I have reformat my machine and reinstall Fedora 33 workstation from ISO already.

After this re-installation, the system now correctly blank the notebook screen.

Before my reformat, I failed to preserve a working snapshot of the problematic instance. Thus I cannot continue to try find out what actually happened to that instance.

Thank you very much to everyone that gave me ideas and helps.


A follow up to my problem.

It turns out even after reinstallation of Fedora 33, Rawhide 34 do not completely fix the “did not blank screen” problem.

While troubleshooting another issue, 1911763 – repeated keycode 227 from Video bus , it turns out adding the a kernel boot parameter also fixed the issue:

sudo grubby --update-kernel=ALL --args=“video.report_key_events=2”

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.