Need help with managing boot, UEFI with new installed F40kde on 2nd SSD

(sorry, newbie warning!)

I was daily driving Manjaro.
The install was on my 1st SSD with all the standard partitions. (efi, boot, root)

Then I installed Fedora40 KDE Spin on a 2nd new and larger ssd.
I think i left everything on standard with the partitions in the GUI installer.

When booting the UEFI didn’t show the new Fedora, only old Manjaro.
Then I had to manually change the booting sequence in the BIOS to move the new SSD infront of UEFI.
I should have already realised it at this moment, but didn’t understand!

When changing the boot priority to the new 2nd ssd, GRUB shows up with both Fedora and Manjaro.
1 week later I realize that I did create a mess and now I want to clean it up.
There is only boot and root on the new SSD.
I had CSM (Compatibility Support Module) active because of old stuff.

Is there a way to easily solve this mess without complete reinstallation?
I would love to stay on Fedora and wipe the 1st SSD because I don’t have a use for Majaro anymore.

Thanks for your help!

Edit1 for more Info:
Checked with

dmesg | grep "BIOS
[ 0.000000] BIOS-provided physical RAM map:
[ … ]
[ 0.000000] SMBIOS 3.3.0 present.
[ 0.000000] DMI: Gigabyte Technology Co., Ltd. X570S AORUS MASTER/X570S AORUS MASTER, BIOS F5e 06/01/2023
[ 0.423168] ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
[ 2.354346] ccp 0000:0f:00.1: ccp: unable to access the device: you might be running a broken BIOS.
[ 3.881771] amdgpu 0000:0d:00.0: amdgpu: Fetched VBIOS from ROM BAR
[ 3.881772] amdgpu: ATOM BIOS: 113-D4120100-100

So, I have a non EFI System?

I am starting to check here.

$ [ -d /sys/firmware/efi ] && echo UEFI || echo BIOS

sudo parted -l

shows that the drive is gpt. Finally something positive.

So I tried to change my partition. For that I changed to Manjaro on nvme1n1 to edit nvme0n1 (Fedora).
I tried to make space by shrinking the root partition to allow movement to create a efi partition before boot. All changes were made with KDE Partition Manager.

nvme0n1 disk

  • nvme0n1p1 | 1M bios?
  • nvme0n1p2 | 1G /boot
  • nvme0n1p3 | shrunk to 400G /root


  • nvme0n1p1 | 1M bios?
  • nvme0n1p2 | 600MB efi
  • nvme0n1p3 |1000MB /boot
  • nvme0n1p4 | 400G /

GOT :frowning:

  • nvme0n1p1 | 1M bios?
  • nvme0n1p2 |1000MB /boot
  • ------------------| 600MB unallocated
  • nvme0n1p3 | 400G unknown

When booting i get to Grub and can select a kernel but then the boot stops and i get dropped in some recovery system.

Can i recover from this. Did I make a simple error?
Thanks for reading!