My computer becomes unusable while a file transfer is in progress

I wonder why I can’t use my laptop when I transfer a bunch of small files or a huge single file from my external USB 3.0 Toshiba hard drive whether it’s connected to the USB 2.0 or 3.0 port, the mouse pointer freezes and I have to wait for the transfer process to complete in order to use the computer again; sometimes the system won’t respond anymore and I have to reboot it by pressing and holding the power button or removing the battery.

Is there some kind of bug related to gnome shell that it’s causing this problem?

1 Like

Same here!

As far as I know, when you are transferring lots of small files or a huge single file, the active HDD/SDD’s I/O (input/output) goes very high, and that means the active disk (the one which is working to perform the copy/cut/paste task on files) is working very hard to perform the task as soon as possible, and when the disk is focused on that task there wouldn’t be much more disk strength (?) left for the other common things that has to be done in the disk to keep the desktop and distribution running smoothly!

Maybe there has to be some dynamic lock/limitation by default for disks I/O on huge file transferring subjects in upstream things (like gnome-nautilus) or downstream things (like kernel) so that all the things can run smoothly while the disk is performing the desired task!

PS. I am having this issue too and I just expressed my thought about this (i.e. maybe this issue is already solved and I’m unaware of it or it’s coming from my lack of knowledge, etc.)!

1 Like

Could be a bug, not seeing it here though. Could just be an I/O blockage as @mohos said.

Could you give us the hardware specficiations of your system please?

Additionally, can you try to transfer files using other methods than gnome-shell’s file-manager (assuming this is what you are using)? Does it happen if you use cp on the command line, for example? or rsync? Please read their man pages for more information on using them. If it’s a gnome-shell thing, then these methods should work better. If you always get the issue, then it’s a kernel I/O thing and we’ll have to investigate if it’s a bug or just general kernel scheduling.

1 Like

I understand what you say but at least I should be able to for example switch to Google Chrome and continue browsing or reading the current page while the transfer is in progress, I know I can’t force the system to do different tasks at the same time but I’ve never had an issue like this under Windows.

Intel® Celeron(R) CPU B820 @ 1.70GHz × 2
mechanical HDD 500GB
Let me know if you need additional info.

I tested an app called freefilesync and I was able to use the computer while the transfer process was in progress.

This is not the most powerful machine, but even then, it shouldn’t block the system so much.

Could you also try cp please? It’s the simplest, most standard tool that doesn’t do anything fancy. Tools such as freefilesync are not—we don’t quite know what they do under the hood.

Could you please provide with a syntax example on how I should use it?, thanks.

man cp or cp --help or an internet search will tell you that. It’s simply:

cp <source file or directory> <target directory>  -av

Please check the documentation for the explanation of -av and other options that you may want to use also.

Thanks for the info. I’m doing it right now as of this writing and I can say the interface becomes laggy but definitely not like using Nautilus, I am able to switch to Chrome and move through the desktop while the copy is in progress but something I didn’t notice is the hard disk LED, it doesn’t blink but keeps steady, it looks like it’s using the whole bandwidth to perform the data transfer instead of being adaptive perhaps?, like the internet?.

Can you please install htop and see the state of your memory (RAM) while data is being copied? I suspect you’re experiencing “swapping”. All your RAM gets used up, so the kernel has to repeatedly move stuff out of it into your swap space (which is your HDD, so much slower).

Happens to me moons ago !
what fedora you are running ?

does it happens usually or did it start suddenly ?
is you box running well ?
No errors, etc. ?

to see if errors: open a terminal and copy&paste in:

dmesg|grep -iEw 'bad|bug|conflict|corrupted|error|fail|failed|fault|fatal|Lock|NULL|segfault|stack|trace|warn'
  • from dmesg until warn’ is ONE line !!!
    the editor here in the forum breaks the above line into two -

what’s the output ?

are you sure your external disk is healthy ?
tried another disk / usb stick ?
is AHCI for your internal disk set in the BIOS ?
Did you try to copy/move files between two partitions on the internal disk [1] ?
same result ?
NO => it’s the external disk [2]
YES => it’s your box => (old) kernel, AHCI in BIOS, USB setting in the BIOS, …

NOT between two directories on the SAME partition

coping/moving files on the same partition does not mean a real file copy / move.
it’s just some pointer manipulations in adminstration unit of directories - sort of -

I got several Toshiba disk with damaged sectors in the past !

Happens to me too. Memory 7.7 GiB, i7 @ 2.20GHz × 8.

I’ve experimented this using an external toshiba disk. Can’t remember if this happens whit a USB stick.

When I need to copy large files, I do it when I’m not using the computer.

Does this happen with other OSes?

It could be normal since that is not a powerful computer, and you’re using a HDD. If the USB is saturated, it could cause user input, which uses USB, to be come laggy.

You can check what’s going on with iotop. You may need to install it.

Don’t do this, especially while there is disk write activity as you risk data corruption.

Now that @stsewd mentions a USB stick, I decided to test one I have, it’s a 32GB Sandisk USB 3.0 pendrive and:

This problem seems to happen only when copying or moving files from external USB storages (HDD or Flash) to home, because when I did the opposite, that is, moving or copying files from HOME to the Toshiba HD or Sandisk drive, I was able to move around the desktop, I was even able to open two applications while the transfer was in progress, so I installed htop as suggested by @FranciscoD and I could take a screenshot when moving/copying files from home to external storages but I was unable to take the screenshot when moving/copying from external storages to home:


PS: I used Nautilus.

1 Like

I did this but nothing happened, it stayed there, doing nothing, should I do anything additional?

you need to hit Enter Key aswell !!!

what up if you temp. create a new user, login in to the new user and copy files to hims home ?

Of course i did!, but nothing happened!

at least you should see something like “bash: …: command not found” if something is wrong.
NO output ???
other point: your mouse cursor should be in that terminal window where you press Enter

and it’s one line:

dmesg | grep -iEw "bad | bug | … | trace | warn’ Enter key.

the only blank which is needed is between grep and “-i”

Sometimes, when copying/moving the file to the external USB flash drive renders the interface unable to respond to mouse clicks, I must wait several seconds to be able to click on any window.

you should nothing do apart the dmesg command, NO copy, anything…