My built-in audio speaker produces low and kinda distorted sound

My audio speaker doesn’t work as well as it should be, as I have tested it in my dual boot windows 11 and It performed well.

The sound works well with my headset and external speakers, but for built-in it’s bad.

My inxi -Fzxx :

System:
  Kernel: 6.6.6-200.fc39.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.40-13.fc39 Desktop: GNOME v: 45.2 tk: GTK v: 3.24.38 wm: gnome-shell
    dm: GDM Distro: Fedora release 39 (Thirty Nine)
Machine:
  Type: Laptop System: ASUSTeK product: ROG Zephyrus G16 GU603VV_GU603VV
    v: 1.0 serial: <superuser required>
  Mobo: ASUSTeK model: GU603VV v: 1.0 serial: <superuser required>
    UEFI: American Megatrends LLC. v: GU603VV.314 date: 09/07/2023
Battery:
  ID-1: BAT0 charge: 89.1 Wh (100.0%) condition: 89.1/90.0 Wh (99.0%)
    volts: 17.2 min: 15.9 model: AS3GWYF3KC GA50358 serial: <filter>
    status: full
  Device-1: hidpp_battery_0 model: Logitech G304 Lightspeed Wireless Gaming
    Mouse serial: <filter> charge: 100% (should be ignored)
    status: discharging
CPU:
  Info: 10-core (6-mt/4-st) model: 13th Gen Intel Core i7-13620H bits: 64
    type: MST AMCP arch: Raptor Lake rev: 2 cache: L1: 864 KiB L2: 9.5 MiB
    L3: 24 MiB
  Speed (MHz): avg: 1879 high: 3800 min/max: 400/4700:4900:3600 cores:
    1: 2235 2: 400 3: 3800 4: 400 5: 400 6: 400 7: 2859 8: 3700 9: 2826 10: 3094
    11: 3585 12: 400 13: 2593 14: 2585 15: 400 16: 400 bogomips: 93388
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: Intel Raptor Lake-P [UHD Graphics] vendor: ASUSTeK driver: i915
    v: kernel arch: Gen-13 ports: active: none empty: DP-1,DP-2
    bus-ID: 0000:00:02.0 chip-ID: 8086:a7a8
  Device-2: NVIDIA AD107M [GeForce RTX 4060 Max-Q / Mobile] vendor: ASUSTeK
    driver: nvidia v: 545.29.06 arch: Lovelace ports: active: none
    off: HDMI-A-1,eDP-1 empty: DP-3 bus-ID: 0000:01:00.0 chip-ID: 10de:28e0
  Device-3: IMC Networks [] driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 bus-ID: 3-7:5 chip-ID: 13d3:56eb
  Display: wayland server: X.org v: 1.20.14 with: Xwayland v: 23.2.2
    compositor: gnome-shell driver: gpu: nvidia,nvidia-nvswitch display-ID: 0
  Monitor-1: HDMI-A-1 model: Acer KG271 P res: 1920x1080 dpi: 82
    diag: 686mm (27")
  Monitor-2: eDP-1 model: TL160ADMP03-0 res: 2560x1600 dpi: 188
    diag: 407mm (16")
  API: OpenGL v: 4.6.0 vendor: nvidia v: 545.29.06 glx-v: 1.4
    direct-render: yes renderer: NVIDIA GeForce RTX 4060 Laptop GPU/PCIe/SSE2
    display-ID: :0.0
  API: EGL Message: EGL data requires eglinfo. Check --recommends.
Audio:
  Device-1: Intel Raptor Lake-P/U/H cAVS vendor: ASUSTeK driver: snd_hda_intel
    v: kernel bus-ID: 0000:00:1f.3 chip-ID: 8086:51ca
  Device-2: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel
    bus-ID: 0000:01:00.1 chip-ID: 10de:22be
  Device-3: JMTek LLC. [] driver: hid-generic,snd-usb-audio,usbhid type: USB
    rev: 1.1 speed: 12 Mb/s lanes: 1 bus-ID: 3-6:4 chip-ID: 0c76:161f
  API: ALSA v: k6.6.6-200.fc39.x86_64 status: kernel-api
  Server-1: JACK v: 1.9.22 status: off
  Server-2: PipeWire v: 1.0.0 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
Network:
  Device-1: Intel Raptor Lake PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 0000:00:14.3 chip-ID: 8086:51f1
  IF: wlo1 state: down mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK driver: r8169 v: kernel port: 3000 bus-ID: 0000:39:00.0
    chip-ID: 10ec:8168
  IF: enp57s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Bluetooth:
  Device-1: Intel AX211 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 bus-ID: 3-10:6 chip-ID: 8087:0033
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.3
    lmp-v: 12
RAID:
  Hardware-1: Intel Volume Management Device NVMe RAID Controller Intel
    driver: vmd v: 0.6 bus-ID: 0000:00:0e.0 chip-ID: 8086:a77f
Drives:
  Local Storage: total: 953.87 GiB used: 19.29 GiB (2.0%)
  ID-1: /dev/nvme0n1 vendor: Western Digital model: WD PC SN560
    SDDPNQE-1T00-1002 size: 953.87 GiB speed: 63.2 Gb/s lanes: 4
    serial: <filter> temp: 32.9 C
Partition:
  ID-1: / size: 123 GiB used: 18.97 GiB (15.4%) fs: btrfs dev: /dev/nvme0n1p9
  ID-2: /boot size: 973.4 MiB used: 250.7 MiB (25.8%) fs: ext4
    dev: /dev/nvme0n1p8
  ID-3: /boot/efi size: 256 MiB used: 81.5 MiB (31.8%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-4: /home size: 123 GiB used: 18.97 GiB (15.4%) fs: btrfs
    dev: /dev/nvme0n1p9
Swap:
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 40.0 C mobo: N/A
  Fan Speeds (rpm): cpu: 2200
Info:
  Processes: 450 Uptime: 11m Memory: total: 16 GiB note: est.
  available: 15.24 GiB used: 5.26 GiB (34.5%) Init: systemd v: 254
  target: graphical (5) default: graphical Compilers: gcc: 13.2.1 Packages:
  pm: rpm pkgs: N/A note: see --rpm Shell: Bash v: 5.2.21
  running-in: gnome-terminal inxi: 3.3.31

Just a thought. Have you tried running a previous kernel version? I had some issues with version 6.6.6 that caused my audio to be unstable. Going to 6.5.6 resolved those issues.

Just a thought.

I tried that solution you mentioned, but unfortunately it didn’t solve the issue.