Mount ntfs drive

Hello. There is a HDD disk, which I always mounted using Gnome Disk Utility with the parameters as in the screenshot. For some reason it doesn’t mount in Fedora 39 and gives an error. What has changed and how to fix it?

P.S. Is it possible to force Loupe to open arw format photos?

Спойлер


I don’t know, but the error says “operation not permitted” when accessing /dev/sdb1. It looks like the “disk” group is allowed access to those devices.

$ ls -al /dev/sdb1
brw-rw----. 1 root disk 8, 17 Mar 21 16:07 /dev/sdb1

Does adding your user to the “disk” group work around the problem?

$ getent group disk
disk:x:6:
$ sudo groupmod -a -U "$USER" disk
$ getent group disk
disk:x:6:gregory

Edit: You might need to sign out and back in for the change to take effect. You can use the id command to verify that the change is active.

Problem solved by setting parameters

ntfs auto,nosuid,nodev,nofail,x-gvfs-show

1 Like

Hi @kichez,

could you please be so kind, and make us a screenshot in English from the Solution? We have a request in Greek, (please follow the link to see on the bottom what I mean.) and I try to help, but unfortunately translating a Image to English is not possible yet or it is very time consuming.

An other option would be that you write instead:

Спойлер (Spoiler alert) {is this Bulgarian?}

The path where you changed the boot options, as title for the Spoiler alert.
Unfortunately I can not do it because I do not have a NTFS drive mounted and can’t speak/read Bulgarian?

p.s.
Text is always better then pictures because of translation, but in your case a picture made sense if it is in English to help others.

This is Russian=) I wrote the mounting parameters in the post above and marked the issue as resolved.