Getting an error on newly formated drive

I just formatted this drive with gnome disk but getting this error after mounting this with the password.

Gnome disk gives this error

This are mounting option from gnome disk

Formatted? or just partitioned and not formatted?

Did you try running sudo mkfs.ext4 /dev/nvme0n1p1 to verify it was properly formatted?
Did you create a standard partition, an LVM partition, or a BTRFS partition (volume).

If it is ext4 then the options are not correct in your second image. Using uid and gid are not required since they would be set by the file system and I am unsure about the x-gvfs-show option. Uid and gid are normally only needed when mounting a fat32 or ntfs volume which does not retain linux style ownership permissions.

Also, you would need to create the mount point (/mnt/stuff) and set the ownership permissions on that directory so the device is mounted with proper ownership before mounting if not already done. After done with disks look at /etc/fstab and verify the device is entered there with the file system UUID and proper mount options.

format, full disk usig gnome disk. and those options are set by the gnome disk, except mount path.

here is the output of the cmd you gave

mke2fs 1.46.5 (30-Dec-2021)
/dev/nvme0n1p1 contains a ext4 file system labelled 'stuff'
	last mounted on Sat Oct 21 19:49:21 2023
Proceed anyway? (y,N) y
Discarding device blocks: done                            
Creating filesystem with 250050816 4k blocks and 62513152 inodes
Filesystem UUID: e543a2cd-0723-43cc-9969-8e13580e13e4
Superblock backups stored on blocks: 
	32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208, 
	4096000, 7962624, 11239424, 20480000, 23887872, 71663616, 78675968, 
	102400000, 214990848

Allocating group tables: done                            
Writing inode tables: done                            
Creating journal (262144 blocks): done
Writing superblocks and filesystem accounting information: done 

after exc your cmd i can mount the disk. it seems that cmd cnages some mounting options

Also how to disable the password promt everytime i try to mount it?

Does the device get entered into /etc/fstab for mounting?
If not, then you cannot disable that password prompt. Mounting by default requires root permissions and since your user is sudo capable giving your password allows mounting when using the disks tool.

If entered into the fstab file with a line such as
UUID=e543a2cd-0723-43cc-9969-8e13580e13e4 /mnt/stuff ext4 nofail,users,defaults 1 2
and the /mnt/stuff mount point has ownership of your user and group, then it would automatically mount and not require you to do mounting at all if the device were attached when booting. If attached at some later time your user could mount it and dismount it (either with disks or from the command line) without the password prompt.

fst tab shows the drive,

Can i do something like reformate the drive so i ca suto mount in the start up?

Your /etc/fstab shows it twice. Once with UUID and a mount point with the uuid name.
Once with the LABEL and the mount point of /mnt/stuff.

  1. It should only be mounted once to avoid other issues.
  2. As I mentioned earlier, the file system is ext4 and really should NOT be using the uid and gid options since that may be contrary to the linux file system ownership and permissions.

I suggest you remove the line in fstab with the UUID entry.
I also suggest you edit the line with the LABEL and modify it to read
LABEL=stuff /mnt/stuff ext4 users,nofail,defaults 0 1
instead of

It is absolutely not required to add all those other options in. The only reason for using ‘nofail’ is to prevent the boot from hanging if the device is not attached and ‘users’ is to allow you to mount it and umount it as a normal user. Once it is properly formatted in /etc/fstab then the device will mount as noted during boot and nothing else is required for normal use.

The uid and gid options are only for use with a device that does not have normal linux file system structure since linux file systems already assign user and group ownership.

As noted also, the directory /mnt/stuff should have its ownership assigned before mounting the device, done with sudo chown $USER:$GROUP /mnt/stuff which will set ownership on that directory for your user. Then mount the drive using mount /mnt/stuff (as your regular user) and repeat the ownership command as sudo chown -R $USER:$GROUP /mnt/stuff which will ensure everything on that drive is owned by your user and group.

From that point on every file written to the device by your owner will be owned by your user and group, and it should be automatically mounted with proper ownership at boot time as long as it is connected.

Please note that it is much preferred to post text you copy from your screen and paste into the document as much as possible since images are not searchable and tend to cut off text that goes beyond the edge of the screen as seen with that line from your fstab file.
The formatting is retained to keep it more readable if you use the preformatted text button </> on the toolbar by selecting the text already pasted then clicking the button.

1 Like