Microsoft Edge update causes SIGILL error on many pages

A part of my yum history summary

    Upgrade       microsoft-edge-stable-112.0.1722.54-1.x86_64 @microsoft-edge
    Upgraded      microsoft-edge-stable-112.0.1722.48-1.x86_64 @@System

I manually had to revert the update with yum downgrade because I got SIGILL on almost every page. Note that I use a VPN on my Fedora workstation.

Happening here too, and not just on Fedora. I’ve narrowed the cause down to the embedded .woff2 font files used by certain sites. Blocking the download of the .woff2 files works around the error and allows the page to load albeit without some fonts rendering correctly.

Edge has just released the new version. Have you tried it yet?

I’m on 112.0.1722.58, still crashing.

Having the same problem with the latest update - Version 112.0.1722.58 (Official build) (64-bit).


Can confirm crashes persist with 112.0.1722.58 via MS Repo on Fedora 37.



I am not sure, but after updating my Edge, it no longer crashes

I ran the update again today, and had to downgrade twice.

My kernel version is 6.2.11-200.fc37.x86_64
Last edge version that worked was microsoft-edge-stable x86_64 112.0.1722.48-1

Running it from a terminal is fine. There is no crash but an error when loading most pages. I suppose kernel plus Feodra version causes some problems that I would not know how to report to Microsoft as well.

i am on fedora 38. May be that is the reason Microsoft Edge crashed.

The two solutions I have seen here:

  1. install the beta or dev version of edge
  2. install the flatpak version (which has some major downsides) using flatpak install flathub

Hello @edwkmho !

No, this is not the reason, I´m on Fedora 37 and have the same problem with the versions since .48 (.54 and .58 at time of writing have crashing plugins and SIGILL on ALL websites), also in other forums (Microsoft we can read of Ubuntu users and others which are affected too.

The only thing they have in common is the version number of microsoft-edge-stable containing 1722.54 or 1722.58.



Thanks for verifying that F37 and other distribution also affected.

Well, just have to wait for Microsoft to fix it. I am moving to other browser.

Edge-Dev from flathub seems to work, got a permission error with Edge-Stable at /tmp/.X11-unix .

I am using the DEV version of the Edge browser and I no longer see the errors, I also clarify that it is the latest version of it, which is: 114.0.1824.4

Version 113.0.1774.35 has just hit the Edge Stable channel, and it seems to have resolved this problem for me.

1 Like

I am unsure whether the issue has been resolved, but it seems that version 113 has a new bug with fractional scaling.


Can confirm that the SIGILL bug is gone with microsoft-edge-stable-113.0.1774.35-1.x86_64 . Took them from of April till of May to fix…