Microsoft Edge Does Not Work

Even after restarting the system, the stable version 112 browser still does not open. I installed it according to the instructions at: How to Install Microsoft Edge on Fedora 38/37/36 Linux

1 Like

Can you run it from a terminal and see what messages you get perhaps?

I’m afraid Microsoft Edge is a proprietary tool so in most cases you’ll have to contact the publishers (Microsoft) to report the issue to them, if they support Linux. It’s quite possible they haven’t updated their packages to support F38 yet.


I think what you said goes with this…

Actually, it works for me, so make sure you are fully upgraded:

sudo dnf upgrade --refresh

If the issue persists, try a new user with default profile settings.

1 Like

And how do i do this?

sudo useradd test
sudo passwd -d test


The friend Ankur may be right.

Does not work.

Hmmm, interesting. I can tell people here that it does 100% work on Fedora 38 I was able to launch all three straight versions away with no issues once I re-installed them in a test, so the statements packages will not work on Fedora 38 is not the problem. I wrote the original article the O.P. linked. So unsure what to say sorry to say without much more information.

Only noticed this thread as a heap of visits came in my referral, but thought I would add my two cents.


I have the same issue with stable version of Microsoft Edge. I did install the beta version of Microsoft Edge and is working for now.

1 Like

Well, this just happened to me.

Is it possible to run it from a terminal to see if any errors are listed? Or does the journal perhaps log any errors? Could just be a missing dependency that the rpm package does not pull in—especially if its working for some and not for others.

As the linked issue above says, microsoft-edge throws SIGILL on my machine as well. The solution as of today was to run

sudo yum downgrade microsoft-edge-stable

twice, ending up on microsoft-edge-stable-112.0.1722.48-1.x86_64 which seems to be the last working version (also on Fedora 38)


Same happened to me after upgrading to Fedora 38 - SIGILL errors in Edge. Since there were other issues I had after upgrading from 37 to 38 (Gimp got very slow, OpenVPN had occasional disconnects, I decided to go clean and went with a clean install of Fedora Workstation 38. On freshly F38 I installed microsoft-edge-stable and it does not even run.

As @petter-k said, 112.0.1722.48-1 does work. Guess it’s MS fault.

Interesting is that just now I decided to use “sudo dnf install microsoft-edge-stable” again, and this time the browser opened! I didn’t even need to use this command with downgrade.

1 Like

I just came across this SIGILL error.

There’s a more suitable thread since the original problem has been solved:
Microsoft Edge update causes SIGILL error on many pages

This doesn’t work for me. I have to downgrade it to 112.0.1722.48-1 version mentioned by @petter-k

1 Like

After upgrading to Fedora 38, Edge failed to open.
Downgrading to 112.0.1722.48-1 via
dnf downgrade microsoft-edge-stable-112.0.1722.48-1.x86_64 solved my issue.