Any solutions for Edge on F38 WorkStation?

First, I have been having problems running the latest version of Microsoft Edge in Fedora 38 WorkStation, leaving a message indicating that it is not possible to start the program and tells me to report the problem, however, it does not indicate the problem as such, but I was able to solve it with information I found in the following links:

  1. Reddit - Dive into anything
  2. Microsoft Edge Does Not Work

Now, I got to solve this and I had help from information that I found in the following link:

Although I solved the execution problem, now I find another, and that is that many pages do not load me.

The pages tell me:

This page is having a problem
Try coming back to it later
You can also:

  1. Open a new tap
  2. Refresh this page

Besides that the error that comes out is:

Error code: SIGILL

I already researched about it, I tried to solve it in various ways, uninstall and install, download from Microsoft’s own page, reinstall the Fedora version, among others, however, I could not solve it. I have followed the steps on this page:

I would like to know if you could help me fix this problem, or tell me if there is a “correct” way to install Microsoft Edge. I would expect that I could help those who work correctly Edge.

This is a known issue discussed here:
Microsoft Edge update causes SIGILL error on many pages

Thanks, I already gave a solution to the problem in that question, which is simply to use Edge Dev instead of Edge