Mac Mini M1: Audio doesn't work in GNOME Fedora 39

Hello, I installed the GNOME version of Fedora 39 on a Mac Mini M1, and I have to say it’s incredible what you achieved, congrats. I’ve found one issue, is that speakers don’t work. The settings seems to recognise well the speakers as Mac Mini J274 Speaker, and i connected earphones with a microphone and they are recognised but they don’t sound and also microphone don’t get sound either. I tried asahi-diagnose, but I didn’t find anything that seemed very wrong, but I encountered one issue in wireplumber.
When i check the status of wireplumber service with systemctl --user status wireplumber i encounter some issues.

I noticed that the error that is shown here happens when i do some audio testing like the left or right speakers on settings. But when i restart the process it shows a different error:

What could be happening?

Thanks in advance

Speakers are not supported on the M1 Mac Mini yet (they were sort of enabled for a long time but not considered properly supported, and I guess something regressed with the draft PipeWire configs).

Once speaker support is rolled out across all machines we’ll fix whatever is wrong here and it will work properly.

I’m not sure what’s up with the headphone jack. It’s possible the speaker breakage is confusing PipeWire?

Today I accidentally noticed that the speaker on my Mac mini (with Fedora Asahi Remix 38 installed) suddenly worked for a while (it’s not recognised as “Mac mini J274 Speaker” anymore, something else but I forgot)…but only for a short time. It seems like after I did a reboot it stopped working again.

OK, I misunderstood that speakers were already supported for the M1 Mac Mini. As for the headphone jack, I also don’t know what could be happening. To be honest, I don’t know much about pipewire. I think that could be what you say, that pipewire is confused by the error.

Thank you Hector!