Linux Nvidia Driver 515.76 causes black screen when booting

I did an update today and tried to reboot with the new kernel: All I got was a black screen.

There’s a thread on reddit with the same problem.

It appears that 5.19.8 kernel works fine for me. Lucky I keep a bunch of them… This is not my first rodeo.

I guess the solution is to wait for an upstream fix. Just make sure you have a old kernel/akmod lying around.

Don’t know what your hardware is but I have

# uname -r

# dnf list installed akmod-nvidia
Installed Packages
akmod-nvidia.x86_64                                                           3:515.76-1.fc36                                                           @rpmfusion-nonfree-updates

and everything seems to work well. I had no problems when upgrading with either one.

RTX3090 connected via HDMI…

Here’s a post from the Nvidia forum


√ ; uname -r
√ ; dnf list installed akmod-nvidia
Installed Packages
akmod-nvidia.x86_64          3:515.76-1.fc36          @rpmfusion-nonfree-updates

So, I run an earlier kernel but the same driver. How odd.

I might note that there seemed to be several issues with the 5.19.8 kernel for some. Maybe this is your issue and the kernel update may help.

I updated to 3.19.12 this morning. That is the kernel that gave me a black screen. I tried going back to 3.19.11 which used to work. It no longer does. Both these kernels give me a black screen.

Kernel 3.19.8 actually works for me. So did 3.19.9 and 3.19.10 (which is the one I am using now) so I have options to still have a running machine. This is nice. :star_struck:

Ok, then it may be that the driver was not properly built for that kernel.

What I have done at times for problems related to video is to

  1. remove the offending kernel in its entirety along with the nvidia drivers.
    sudo dnf remove kernel*5.19.12* *nvidia*
    Note that this will not affect the current running system since the modules are already loaded.
  2. reinstall the updated kernel
    sudo dnf upgrade --refresh
  3. reinstall the nvidia drivers with cuda
    sudo dnf install akmod-nvidia xorg-x11-drv-nvidia-cuda
  4. wait at least 5 minutes to ensure the modules have time to rebuild.
  5. verify the modules have been built
    sudo dnf list installed kmod-nvidia
  6. after step 5 shows the kmod has been built properly then reboot.

I developed this procedure after seeing a similar issue with an update back in fedora 34 and it has worked a couple times with issues since.

AFAICT it seems it may be related to rebooting too soon after an update so the modules are only partly built and thus fail to function.

Ooh, hope they fix that for HDMI-users soon (DP user here and just upgraded and saw this).

The only time I have seen this on my desktop was with 5.19.8 & 5.19.9. Nothing else has done so before or after. I simply booted to the older kernel and followed the steps above and it booted properly the next time.

Today was another adventure! No kernel booting… At all. None of them.

Until 3.19.12 started to work… I mean, that’s the one that was not working before! \gif WOT?

I tried @computersavvy 's solution — well, re-installing all things nvidia. I am now dreading rebooting my machine!

Nope. It was hell. Nothing whatsoever worked.

Finally, GoastRiter managed to get it to work. It is a hack but will carry you through till Nvidia releases a none-broken driver.

NVArchive: NVIDIA Driver Archives for Fedora.

Follow these steps… Get an old driver working with your new kernel.