Latest update with kernel broke nvidia

latest update with latest kernel broke nvidia it cant communicate with drivers please update drivers

NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.
tried install drivers again still same issue

1 Like

Same here on my rig with a RTX 4070. I get a black screen after the BIOS with the latest kernel update (6.9.5). I had to select the previous kernel (6.9.4) to boot after a forced shutdown.

No boack screen falling back to nouavue and can’t detect or see Nvidia drivers or communicate.

Trying to reinstall drivers is just nothing to do all done already

OK, so maybe not exactly the same problem, but nvidia related with the latest kernel

Someone else posted a similar issue with kernel 6.9.5 and Nvidia drivers on Reddit:

fwiw, I’m using nvidia 550.90.07 drivers and can’t boot to kernel 6.9.5

I can still only boot to kernel 6.9.4

Hello there,

I have no issue at all with Kernel 6.9.5-200.fc40.x86_64 and Nvidia driver 550.90.07 with a RTX 3080 Ti
I’m on KDE Plasma 6.1.0 (on x11 until Nvidia 555 comes out)
If it can help.

I reinstalled vanilla Fedora from scratch on the rig where I have my 4070 and it gets a complete black screen as soon as it tries to boot kernel 6.9.5.

I don’t think this is necessarily related to the nvidia drivers anymore in my case. I’m able to boot any previous kernel before 6.9.5.

Now I have to figure out how to install 6.9.4 on my new installation and pinned it until a newer kernel is released, hoping it will boot well on my rig.

More details on the rig I’m having trouble with:

-Ryzen 7 7745HX
-RTX 4070 Super

You are using RPMFusion repo right?


In my case I use RPMFusion.

I reinstall vanilla F40 from scratch on my rig just to be 100% sure. After fully updating and rebooting with 6.9.5, no problem.

Once I install the nvidia drivers from RPMfusion:

sudo dnf install akmod-nvidia xorg-x11-drv-nvidia-cuda

and reboot, complete black screen. I then have to select the previous kernel to reboot. Even after removing the two nvidia packages, 6.9.5 still refuses to boot.

So the problem in my case is the nvidia drivers interaction with the 6.9.5 kernel.

EDIT: And again, the RPMFusions nvidia drivers worked fine on the same rig before the 6.9.5 kernel upgrade.

1 Like

Added kernel, rpmfusion

Added f40

Yeah rpm fusion repo all was working as should with secure boot etc and after update it is dead

1 Like

Hmm, good to know. I’m not on RPMFusion repo and I have the Nvidia 555.52.04 driver.

I have 2 different machines. Both are f40 and were updated to the 6.9.5 kernel. The updates were done using dnf and allowing plenty time between the kernel update and the reboot to the new kernel.

Both are working well.
My laptop has the 550.90.07 driver from rpmfusion
My desktop has the 555.52.04 from rpmfusion with using --releasever=41 since that version is in testing for rawhide at present.

I don’t know how you performed the updates but you may be a victim of the issue which has a solution here.

It seems that frequently when using the gui (gnome software) to do updates, the reboot may occur too quickly after the upgrade completes and the driver may not be properly and completely built before that reboot so it fails. The same seems to occur at times when doing the update with dnf using the --offline option.

1 Like

I updated using dnf and reboot was hours after update need to check today if I have time to open my laptop and try to fix the issue without reinstall

I am tho on hybrid system again Intel with Nvidia and laptop GPU rtx 3050 TI I remember it had similar issues on F40 testing on some users especially using laptop GPU and hybrid systems

On a fresh new vanilla F40 installation, I tried the workaround you just posted.

This almost completely solved my problem. Here is what I did:

  1. Reboot the PC and hold down Shift while booting, this will bring up the GRUB2 boot loader menu.

  2. Press e to edit kernel 6.9.5, find the linux line and add nomodeset plymouth.enable=0 at the end of it. Then press ctrl+x to boot.

  3. Log in to GNOME in low resolution.

  4. Run the following commands in a terminal

sudo dnf remove ‘kmod-nvidia-*’
sudo akmods --force

  1. Reboot the system.

  2. After getting the same black screen. I then did step 1 and 2 again and surprise, surprise, I managed to log in to GNOME at full resolution with kernel 6.9.5 and the nvidia drivers working fine.

  3. Reboot a couple more times and realize that the only way to boot properly is to repeat step 1 and 2 every time.

Note: I then re-enable secure boot and need to re-import the keys as described in:

So now it works, but I guess I will have to make nomodeset plymouth.enable=0 persistent in grub to avoid the black screen until the next kernel upgrade. Unless someone has a better workaround…

What you are doing is only a temporary edit of the kernel command line that applies only for that current boot.

It seems strange that after using steps 1 & 2 (which disables plymouth and modeset) that the system will boot into normal graphics mode as shown in step 6.

You might try (one at a time) an update which works properly before you make those options permanent.
First the plymouth disable with only adding the ‘plymouth.enable=0’ in step 2 of your boot.
If that works properly then only make that one permanent.
If that fails then try the ‘nomodeset’ option in step 2 and see if that works. If it does then only make that one permanent.

You should be able to add those options permanently for kernel 6.9.6 with
sudo grubby --update-kernel=6.9.6-200.fc40.x86_64 --args=plymouth.enable=0
then reboot and see if it boots normally.
sudo grubby --update-kernel=6.9.6-200.fc40.x86_64 --args=nomodeset

The boot results should be the same as when you did that by editing the grub command line in step 2. If necessary to use both options then use both commands.

Before you do the above I would ask that you send the output of cat /proc/cmdline when booted so we can see exactly what is there before modifying it. There may be a different solution.

1 Like
phatle@fedora:~$ cat /proc/cmdline
BOOT_IMAGE=(hd0,gpt2)/vmlinuz-6.9.5-200.fc40.x86_64 root=UUID=f5b852d6-6d23-45ff-bacc-848fc7bd6711 ro rootflags=subvol=root rd.driver.blacklist=nouveau modprobe.blacklist=nouveau rd.luks.uuid=luks-9ddf48b0-bfa0-48cc-920a-0b7c6cfe01fb rd.luks.uuid=luks-ca855f38-7155-476d-b939-c8f567afabee rhgb quiet rd.driver.blacklist=nouveau modprobe.blacklist=nouveau

logs shows only that it cant load nvidia drivers

I removed nomodeset from my permanent grub config and rebooted again and it worked just as well.

Here’s the output of ‘cat /proc/cmdline’ now that I’m logged into GNOME with kernel 6.9.5 and the nvidia drivers working:

BOOT_IMAGE=(hd0,gpt2)/vmlinuz-6.9.5-200.fc40.x86_64 root=UUID=cd82f51b-9651-47fd-97c2-ca9b6b456bd9 ro rootflags=subvol=root rd.driver.blacklist=nouveau modprobe.blacklist=nouveau rd.luks.uuid=luks-4d6fb1a6-65ec-453e-8d23-70bd03433cfe rhgb quiet rd.driver.blacklist=nouveau modprobe.blacklist=nouveau plymouth.enable=0

i found there was kmod kernel 6.94 and 6.9.5 on my system workstation 40 and running sudo kmod remove 'kmod-nvidia-*' and sudo akmods --force removed both and installed only latest 6.9.5 and then it detects nvidia again

phatle@fedora:~$ modinfo -F version nvidia
modinfo: ERROR: Module nvidia not found.
phatle@fedora:~$ sudo dnf remove 'kmod-nvidia-*'
Place your right index finger on the fingerprint reader
Dependencies resolved.
 Package                          Arch   Version            Repository     Size
                                  x86_64 3:550.90.07-1.fc40 @@commandline  41 M
                                  x86_64 3:550.90.07-1.fc40 @@commandline  41 M

Transaction Summary
Remove  2 Packages

Freed space: 82 M
Is this ok [y/N]: y
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                        1/1 
  Erasing          : kmod-nvidia-6.9.5-200.fc40.x86_64-3:550.90.07-1.fc40   1/2 
  Running scriptlet: kmod-nvidia-6.9.5-200.fc40.x86_64-3:550.90.07-1.fc40   1/2 
  Erasing          : kmod-nvidia-6.9.4-200.fc40.x86_64-3:550.90.07-1.fc40   2/2 
  Running scriptlet: kmod-nvidia-6.9.4-200.fc40.x86_64-3:550.90.07-1.fc40   2/2 


phatle@fedora:~$ sudo akmods --force
Checking kmods exist for 6.9.5-200.fc40.x86_64             [  OK  ]
Building and installing nvidia-kmod                        [  OK  ]
phatle@fedora:~$ modinfo -F version nvidia

it worked for me now after reboot all good again