Kernel 5.5.15-200.fc31 has corrupted Nvidia driver

so i had Nvidia working fine with every Kernel since the installation of fedora 31. however 5.5.15 has made Nvidia Driver not working i have GTX 1060.

We need to confirm a few things first:

  • when you meant the Nvidia driver, do you mean the nouveau driver that is included in the kernel or have you installed the proprietary Nvidia driver?
  • if you installed the proprietary driver, how did you install it?

The Rpm fusion proprietary nvidia Driver.
Installed using The guide on rpm fusion website

maybe wait for “sudo dnf info akmod-nvidia” showing the 440.82 version that got out April 8

Do you get a black screen?

uninstalled Nvidia and rebooted,
then installed Nvidia again which caused an issue on boot
" Failed to start Switch Root " ( os-release not in sysroot os tree ) "

booted and chrooted from usb drive:

  • Tried to reinstall the nvidia again
  • reinstall kernel
  • reinstall systemd
  • put os-release in /sysroot/etc
  • booting from another kernel

non of these have worked.

ended up reinstalling fedora and recovering old home dir since it was on another partition.
still no idea why / how the issue was caused…

Oh… (a)kmod-nvidia, “just” have been bump from 440.64 to 440.82 in rpmfusion nonfree updates testing!

1 Like