Libvirtd stop responding after some time

I’m running minikube VM inside KVM. Everything works well for few minutes than minikube stops responding.
I tried looking if minikube VM was running using the following command:-

sudo virsh list --all

But this command hangs.

I did some digging in the web. I came up to a the following website:-
which had similar issue where sudo virsh list --all command will hang and it was because libvirtd stop responding. And if we restart libvirtd the problem seems to go away for some time.
I restarted libvirtd we the following command.

sudo systemctl restart libvirtd

It solves the problem for some time but It appear again. In following website the author seemed to have solved the problem, but I found it too technical and could not understand what he did and how he did it.

It it would helpful if some one could give me clear direction on how to solve this problem.

btw, the problem started happening after i updated libvirt, if i can recall correctly and I also tried reinstalling @virtualization group that contains libvirt, kvm, qemu, etc but problem persist.

You might check the journal to see what happens before and after the problem.

You could do this with something like that:

journalctl |grep -B 3 -A 3 libvirtd*
sudo tee /etc/sysconfig/virtnetworkd << EOF > /dev/null
sudo systemctl enable virtnetworkd.service
sudo systemctl restart virtnetworkd.service

2213660 – libvirt clients hang because virtnetworkd.service misses when virtnetworkd is dead


Thank you.
Now everything works fine.

I thought so too, but that hasn’t fixed the problem for me. If anything, it made it worse…

Sounds like this systemd bug:

fixed in this update (in updates-testing and going stable in a few):

1 Like

Of course I missed the very first, and important line from @vgaetera’s comment.

sudo tee /etc/sysconfig/virtnetworkd << EOF > /dev/null

That does work for me.

With the new update of systemd this morning, the problem is fixed, and the various workarounds can now be undone.

Current version of systemd is systemd-253.7-1.fc38.x86_64.


hm, I still have this problem.

I tried the Distrobox method of isolating the virtualizer and the viewer, which is pretty cool. It worked the first time, after reboot I can’t connect anymore at all, even though the podman container is running and sshd and libvirtd are…

Then I tried it again locally, using rpm-ostree I removed the qemu qemu-kvm virt-manager packages, rebootet, layered them again.

Still, no connection possible.

I tried setting the argument, restarting the services, rebooting, everything…