Qemu:///session hangs, systemctl restart libvirtd required

Since update to Fedora 38 using vagrant --debug up displays

 INFO machine: Initializing machine: default
 INFO machine:   - Provider: VagrantPlugins::ProviderLibvirt::Provider
 INFO machine:   - Box: #<Vagrant::Box:0x00007f45425ac7b8>
 INFO machine:   - Data dir: /home/user/vagrant/.vagrant/machines/default/libvirt
 INFO driver: Connecting to Libvirt (qemu:///session) ...

which hangs indefinitely.

Workaround: sudo systemctl restart libvirtd.service

Used to work in Fedora 36.

Any ideas?

Could be this one 2213660 – libvirt clients hang because virtnetworkd.service misses when virtnetworkd is dead, see also a similar post: Libvirtd stop responding after some time - #3 by vgaetera

Thank you Flo.

The following seems to have worked:

sudo systemctl enable virtnetworkd.service
sudo systemctl restart virtnetworkd.service

The service was disabled and not running. Not sure why. I tried sudo dnf reinstall libvirt-daemon-driver-network but the service was still disabled.

It will be fixed when systemd-253.5-3.fc38 or 253.6 will be staged and hits the repo.


You can subscribe to the bug report on bugzilla (linked above) and get notified when a fix lands in the updates (or updates-testing) repo.

Thanks Flow.

Just fyi:
Unfrotunately, above did not fix it permanently.
I can either restart libvirtd or virtnetworkd which revives connection.

It is usually socket activated, that is virtnetworkd.socket is enabled and active, and when virtnetworkd.serviceis needed it will be started automatically.