Not start after boot

How can I solve this problem? I tired sudo systemctl enable libvirtd

But didnt work. Just showed this:

Failed to enable unit: Unit file libvirt.service does not exist.

sudo systemctl status libvirtd

○ libvirtd.service - Virtualization daemon
Loaded: loaded (/usr/lib/systemd/system/libvirtd.service; enabled; preset: disabled)
Active: inactive (dead)
TriggeredBy: ○ libvirtd-tls.socket
○ libvirtd-ro.socket
○ libvirtd-admin.socket
○ libvirtd.socket
○ libvirtd-tcp.socket
Docs: man:libvirtd(8)

Because that time you typed libvirt not libvirtd.

Oh I know I just misspelled sorry but if I enable it even if the machine boots I have to start it manually because it won’t start, how can I fix that?

By using sudo systemctl enable libvirtd.service , you might have to enable the libvirt daemon. Or reinstall it can helpful.

The libvirt daemons was changed a while ago. It is now split up into multiple daemons, although the old single daemon version is still provided.

By default the following units are enabled


and all libvirt units are all disabled.

This can be seen when running systemctl list-unit-files '*virt*'.

Also bear in mind that the libvirt daemon will shutdown if inactive for two minutes. but will be automatically re-started when trying to use it.

I have done what you said several times, reinstalled and enabled it several times

I am unsure what the problem might be.
On my system I installed libvirt then created a VM and it works.

I think the daemon remains idle until the user launches (powers on) the VM that was created but I never had to do anything else but launch the VMM from the menu then start the VM and it is always active.

I did have to install virt-manager to be able to create and manage the VMs from the desktop, but nothing else since all the libvirt packages were installed by default on my F37 system. If you look at the status of the libvirtd.service on F37 this is the default status.

# systemctl status libvirtd.service
○ libvirtd.service - Virtualization daemon
     Loaded: loaded (/usr/lib/systemd/system/libvirtd.service; disabled; preset: disabled)
     Active: inactive (dead)
TriggeredBy: ○ libvirtd-admin.socket
             ○ libvirtd.socket
             ○ libvirtd-ro.socket
             ○ libvirtd-tls.socket
             ○ libvirtd-tcp.socket
       Docs: man:libvirtd(8)

Until you have created a VM and it is running this is what you will see.

The man page says this:

       The libvirtd daemon is capable of starting in two modes.

       In  the  traditional  mode, it will create and listen on UNIX sockets itself.  If the --listen parameter is given, it will also listen on TCP/IP socket(s), according to
       the listen_tcp and listen_tls options in /etc/libvirt/libvirtd.conf

       In socket activation mode, it will rely on systemd to create and listen on the UNIX, and optionally TCP/IP, sockets and pass them as  pre-opened  file  descriptors.  In
       this  mode,  it is not permitted to pass the --listen parameter, and most of the socket related config options in /etc/libvirt/libvirtd.conf will no longer have any ef‐
       fect. To enable TCP or TLS sockets use either

          $ systemctl start libvirtd-tls.socket


          $ systemctl start libvirtd-tcp.socket

       Socket activation mode is generally the default when running on a host OS that uses systemd. To revert to the traditional mode,  all  the  socket  unit  files  must  be

Since Fedora uses systemd the last sentence there is important. It is started by the socket mode, and does not run constantly.

so like this?

and i got this after enabled all services and started libvirted.service

After reboot I started libvirted it manually and got this: