Virt-manager not connecting to Qemu

Hi everyone, sometimes I open virt-manager and is not connecting to Qemu, rebooting fixes the issue but is annoying.
Schermata del 2023-07-18 18-58-25

How can I check if the Qemu / Libvirt services are working fine?

Libvirtd stop responding after some time - #3 by vgaetera


i’ve had it happen on occasion after i wake my laptop up from sleep:

sudo systemctl restart libvirtd.service


I had the same issue. This solved it Libvirtd stop responding after some time - #3 by vgaetera

I dont know how to solve this problem…

I already tried all this:

sudo rm -rf /etc/libvirt
sudo rm -rf /var/run/libvirt #aufpassen mit bestehenden images!

dconf reset -f /org/virt-manager/

sudo systemctl restart libvirtd

It just worked forever. Layer qemu qemu-kvm virt-manager and it just worked.

now it cant find a connection, at all. I tried everything, its nuts

Rebooted, worked again.

But it didnt show any virtual network.

So I ran some commands recommended in a CentOS forum, creating network “default” did not work.

But in the meantime, my virt-manager popup was gone and there only was the blank selection screen with " Qemu not connected".


Manually removing files and directories that are installed by a package tends to break the package and sometimes dnf which manages that package.

You might try dnf reinstall qemu* libvirt* virt* to see what that may do in bringing back the services. It should verify the packages, reinstall them, and create new files and directories that may have been manually removed.

1 Like

Thanks! Its rpm-ostree though, and I already tried uninstalling, rebooting, layering, rebooting.

Now for some reason it works again. But there is no network device which is otherwise shown by default. Tried adding one, but afaik you cant edit a VMs config once created? I searched everywhere, is this a thing, that “edit VM configuration” is only possible during creation?

Apart from that for some reason the rpm-ostree layered version is working again. And I am not touching the containerized virt-manager anymore as I have the feeling they put stuff in home and conflict.

No where above do I see that mentioned, nor did I see any mention of vm until this post.

Full details make it easier for us to provide meaningful answers.

In fact with a VM using libvirt and virt-manager it is quite possible to change network config for the VM system.

Having a feeling is not the same as fact. As far as I know virt-manager does not put anything into a users home directory. Everything done with virt-manager seems to be placed under /var/lib/libvirt/ or one of /etc/libvirt* or /etc/qemu*.
That said, I have no experience with containerized usage so cannot address that part.

I created a new post about this.

The regular layered qemu qemu-kvm virt-manager and some day no connection anymore.

Then I tried the distrobox stuff and it worked, after a reboot not anymore, so back to normal again.

Now for some reason QEMU connection seems to be reliable, but the virtio network device is gone.

Thanks for supporting me!

I normally use bridged networking and use the default virbr0 device when I configure a VM since I want direct access from the host to the VM. I also use wifi only and bridging does not seem to work with a bridge device created using the wifi adapter but apparently only works properly with wired interfaces. Using NAT for the networking makes it difficult for the host to connect to the VM.

1 Like