Libssl.so.1.0.0

Hi, I installed a game, Baldur’s Gate, but it says that the libssl.so.1.0.0 library was not found. What do I need to do to install this library?

I found some old topics talking about this is provided by openssl-libs, so try installing that package. The GitHub page for OpenSSL also says it provides the libssl package so hopefully that is a good bet.

⬢[matthew@toolbox ~]$ sudo dnf info openssl-libs
Last metadata expiration check: 0:01:23 ago on Sat 02 Dec 2023 04:20:01 PM EST.
Installed Packages
Name         : openssl-libs
Epoch        : 1
Version      : 3.1.1
Release      : 4.fc39
Architecture : x86_64
Size         : 7.8 M
Source       : openssl-3.1.1-4.fc39.src.rpm
Repository   : @System
From repo    : anaconda
Summary      : A general purpose cryptography library with TLS implementation
URL          : http://www.openssl.org/
License      : Apache-2.0
Description  : OpenSSL is a toolkit for supporting cryptography. The openssl-libs
             : package contains the libraries that are used by various applications which
             : support cryptographic algorithms and protocols.

Didn’t solve it, but thanks anyway, i need the 1.0.0 version.

Try doing a dnf search for a openssl compatibility library.
I know there is a openssl 1.1 cannot recall if there is a 1.0.

But if you can find an old enough RPM for an old fedora it will have 1.0 .so toy need that you can put in its own dir and point LD_LIBRARY_PATH at for running bg.

Get the library from the Steam package and load it with LD_LIBRARY_PATH.

3 Likes