/lib64/libldap.so.2: undefined symbol: EVP_md2, version OPENSSL_3.0.0 after upgrading from F35 to F37

Hi there!

I recently upgraded my Fedora from 35 to 37. After upgrade, I see the following error when trying to use dnf, flatpak, NetworkManager, etc.

ImportError: /lib64/libldap.so.2: undefined symbol: EVP_md2, version OPENSSL_3.0.0

I’ve tried to check if there any obvious problems using rpm -aV but I don’s see any missing or unresolved dependencies.

I’ve also tried to upgrade openldap manually from updates-testing, but the problem is still there.

rpm -q openldap

rpm -qf /usr/lib64/libldap.so.2 

rpm -q openssl

I’ve found where the problem is while writing the question :slight_smile:

The problem was with the Dell Command package (command-configure)

openssl version
openssl: /opt/dell/dcc/libcrypto.so.3: version `OPENSSL_3.0.9' not found (required by openssl)
openssl: /opt/dell/dcc/libcrypto.so.3: version `OPENSSL_3.0.1' not found (required by openssl)

rpm -e command-configure 

openssl version
OpenSSL 3.0.9 30 May 2023 (Library: OpenSSL 3.0.9 30 May 2023)


You do realize that Fedora 37 will go EOL in just over a month, and will get no further updates after that happens?

I would suggest that you do a full update of F37 with dnf upgrade --refresh then upgrade the next step to F38 before F37 goes EOL.

Yep, this is exactly what I am planning to do :slight_smile:

The Software app provided access only to the Fedora 37 upgrade (from Fedora 35), not Fedora 38, unfortunately.

Fedora does not recommend moving more than 2 versions at one time and the gui software app enforces that recommendation. From the command line it is possible to do an upgrade of more versions at one time but doing so risks breaking the system since there are often significant changes between versions and those changes may not be compatible across several versions at once as a single step.