[CLOSED] Flatpak Symbol Lookup Error - OpenSSL

Hi there,

when I run

flatpak update

or other flatpak commands, such as

flatpak remotes

I get the following error message:

flatpak: symbol lookup error: /lib64/libldap.so.2: undefined symbol: EVP_md2, version OPENSSL_3.0.0

My System (Fedora 38) is up to date - probably not by flatpak apps of course, but by sudo dnf update --refresh -y.

My OpenSSL version is also up to date (Package openssl-1:3.0.9-1.fc38.x86_64):

~ openssl version
OpenSSL 3.0.9 30 May 2023 (Library: OpenSSL 3.0.9 30 May 2023)

Before this error started occurring yesterday, I had also experienced the issues presented in this post:

I have not done anything to fix this previous issue, as well as no actions (because no idea and no google results) for my current issue.

I would appreciate any help!



What seems to help is to call all flatpak commands using sudo - similarly to Flatpak install/update fails with "Need more input" or "Input buffer too small".

Solved by uninstalling anaconda and installing mamba!