Libreoffice 7.25 toolbars are too small to be readable

With the last update in fedora 35 Libreoffice toolbars are too small to be readable. I even tried to download the appimage version of libreoffice but the problem remains the same.
Is it a libreoffice or Fedora 35 problem?
How to solve it?
Thank you in advance to anybody willin to help me

1 Like

There are many options within libreoffice to adjust it to your own needs. Try searching the links on the toolbar, including especially the tools tab, and change the preferences to what works for you. You might also try using the “help” tab to get detailed info for your needs.

Arbitrarily switching from rpm to flatpak does not (to me) seem a reasonable approach. You have to uninstall the many rpm parts of libreoffice before you install the flatpak to avoid potential conflicts. The rpm versions are tested and work and are part of the fedora repos. The flatpak versions are not the same and often carry some other cruft that is designed to work when not all the native OS properly supports the app.

Thanks for your answer.
The image I posted has already the icons at their maximum size. I didn’t find any other setting that could help solve the problem.
I didn’t use a flatpack to countercheck the problem, but an appimage as it does not need to be installed to run.
The problem is still there.
It looks as a rendering problem: the PC that showed the problem is a spectre x-360 with a 15"screen at 4k that needs a magnification of 160 in fedora to work and 225 in windows, running f35 KDE in wayland.
Another, much older, pc with a 17" screen at 1920x1080 resolution, running F35 KDE in X-Org mode does not show this problem. Both pc’s have an nvidia video card.
To deepen the problem I will try libreoffice on the first PC in x-org mode and then I will try on both PCs an appimage of Libreoffice 7.3 to see if this solves the problem, and then report the results.

1 Like

I’m on Gnome + Wayland here, and the icon sizes seem fine.

Are you using the default theme + icon set, or are you using a custom theme/icon set perhaps?

A simple check is to create a new user and see what happens there. If you get the expected behaviour in the new user, then it’s something most likely related to your user config/customisations.

May be you also want to check the DPI setting and set it to 96. But unfortunately I can’t recall where the setting is, either on Fonts setting or Display setting (no longer have system with KDE).

From your image above, on part font setting, that look weirdly too small. From that, it must be DPI related setting.

Thanks for all your answers. It looks as a wayland rendering problem: In the x11 desktop the problem disappears, on a fresh installation, done on an external disk , the problem in wayland is still present. The dpi forcing setting did not work, even forcing at 110.
The bad news are that the problem is present even in libreoffice 7.3, tested from an appimage.
Now the possible culprits are:

  • The Nvidia driver
  • Wayland
  • Libreoffice

Where should I file the bug?

Before file a bug, you should give us information like:

inxi -Fzx in terminal and post the output as </> Preformatted text here.

So we can see what exactly you are using. Might be that there is a other driver who fits better to your GPU etc.

1 Like

A 15" screen at 4k is too tiny for my eyes. In gnome you have the option to set the resolution to 100% or 200% with X. I don’t know how that is done in KDE. You already said you have it set for 160 in fedora so maybe try enlarging the display a bit more and see what happens.

My inxi output (nice bash offering to install missing commands, when this feature was added?):

  12Kernel 5.16.8-200.fc35.x86_64 x86_64 12bits 64 12compiler gcc 12v 2.37-10.fc35
    12Desktop KDE Plasma 5.23.5 12Distro Fedora release 35 (Thirty Five)
  12Type Convertible 12System HP 12product HP Spectre x360 Convertible 15-df0xxx 12v N/A 12serial <filter>
  12Mobo HP 12model 8518 12v 10.73 12serial <filter> 12UEFI AMI 12v F.45 12date 07/09/2021
  12ID-1 BAT0 12charge 59.0 Wh (76.8%) 12condition 76.8/76.8 Wh (100.0%) 12volts 11.7 12min 11.6
    12model HP Primary 12status N/A
  12Device-1 hid-0018:04F3:2816.0001-battery 12model ELAN2514:00 04F3:2816 12charge N/A 12status N/A
  12Info quad core 12model Intel Core i7-8565U 12bits 64 12type MT MCP 12arch Whiskey Lake 12rev B 12cache
    12L1 256 KiB 12L2 1024 KiB 12L3 8 MiB
  12Speed (MHz) 12avg 867 12high 900 12min/max 400/4600 12cores 121 890 122 900 123 900 124 900 125 647 126 900 127 900
    128 900 12bogomips 31999
  12Flags avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  12Device-1 Intel WhiskeyLake-U GT2 [UHD Graphics 620] 12vendor Hewlett-Packard 12driver i915 12v kernel
    12bus-ID 00:02.0
  12Device-2 NVIDIA GP108M [GeForce MX150] 12vendor Hewlett-Packard 12driver nvidia 12v 510.47.03
    12bus-ID 3b:00.0
  12Device-3 Lite-On HP Wide Vision FHD Camera 12type USB 12driver uvcvideo 12bus-ID 1-5:2
  12Display wayland 12server X.Org 12compositor kwin_wayland 12driver 12loaded modesetting,nvidia
    12unloaded fbdev,nouveau,vesa 12resolution 2392x1349~60Hz
  12OpenGL 12renderer Mesa Intel UHD Graphics 620 (WHL GT2) 12v 4.6 Mesa 21.3.6 12direct render Yes
  12Device-1 Intel Cannon Point-LP High Definition Audio 12vendor Hewlett-Packard
    12driver sof-audio-pci-intel-cnl 12bus-ID 00:1f.3
  12Sound Server-1 ALSA 12v k5.16.8-200.fc35.x86_64 12running yes
  12Sound Server-2 PulseAudio 12v 15.0 12running no
  12Sound Server-3 PipeWire 12v 0.3.45 12running yes
  12Device-1 Intel Cannon Point-LP CNVi [Wireless-AC] 12driver iwlwifi 12v kernel 12bus-ID 00:14.3
  12IF wlp0s20f3 12state up 12mac <filter>
  12Device-1 Intel Bluetooth 9460/9560 Jefferson Peak (JfP) 12type USB 12driver btusb 12v 0.8
    12bus-ID 1-10:4
  12Report rfkill 12ID hci0 12rfk-id 0 12state up 12address see --recommends
  12Local Storage 12total 2.75 TiB 12used 441.45 GiB (15.7%)
  12ID-1 /dev/nvme0n1 12vendor Toshiba 12model N/A 12size 953.87 GiB 12temp 39.9 C
  12ID-2 /dev/sda 12type USB 12vendor Sabrent 12model External 12size 1.82 TiB
  12ID-1 / 12size 47.81 GiB 12used 23.42 GiB (49.0%) 12fs ext4 12dev /dev/sda3
  12ID-2 /boot/efi 12size 199.8 MiB 12used 13.9 MiB (6.9%) 12fs vfat 12dev /dev/sda1
  12ID-3 /home 12size 850.85 GiB 12used 310.67 GiB (36.5%) 12fs ext4 12dev /dev/sda4
  12ID-1 swap-1 12type partition 12size 17.09 GiB 12used 0 KiB (0.0%) 12dev /dev/sda5
  12ID-2 swap-2 12type zram 12size 8 GiB 12used 0 KiB (0.0%) 12dev /dev/zram0
  12System Temperatures 12cpu 65.0 C 12pch 59.0 C 12mobo N/A
  12Fan Speeds (RPM) N/A
  12Processes 455 12Uptime 12m 12Memory 15.24 GiB 12used 3.74 GiB (24.6%) 12Init systemd 12runlevel 5
  12Compilers 12gcc 11.2.1 12Packages N/A 12note see --pkg 12Client Unknown Client: pk-command-not-found
  12inxi 3.3.12

About the scale factor, this is the KDE panel:

As youcan see there is an associated virtual resolution of the monitor that changes with the scale factor. With 160 the virtual resolution is 2400x1350 that has an aspect ratio of 16:9, equal to the native aspect ratio of the monitor. The other possible value for the scale factor is 200 with a viortual resolution of 1920x1080. The last one was chosen by anaconda during the fresh installation on an external disk, but the results are similar and the defect is still there.
Tomorrow I hope to have the time to uninstall the Nvidia driver and see if with nouveau the problem persists.

Wow, Where did all the 12s come from in your inxi output. Must be something to do with your system since I have never seen that before.

2 comments and hopefully a couple ideas.

  1. You are using wayland and I wonder if you have tried X to see if there is any difference. Don’t know if that would change things but might be worth a try.
  2. I don’t see what version of the nvidia driver is installed but I do know that the latest version (510.47 at present) has had tweaks to support wayland, but as yet is still not 100% there. I also know that installing from the rpmfusion repo gets a version that is already tweaked for use with fedora and installing the version directly from nvidia is slightly different. This is something to consider as well.

I found this on the internet: 137924 – [KF5] UI not scaled correctly on HIDPI Wayland/KDE screens

There some users successfully fixed the problem with various workaround. May be you want to try some of them.

It’s PackageKit, not bash:

1 Like

@ Jeff V: I run fedora from an external NVME SSD. May this explain the “12”?

@ Syaifur Rizal: very interesting! It looks like this is a well known bug that will have an official solution with QT 5 and libreoffice 7.3x (Fedora 36?).
In the mean time Iĺl have to play with the system.
I will come back with the results.

Thank you all

1 Like

Not likely. It seems almost as if you were copying the text as html or similar, not actually as text.

Did you by chance use a windows system to manage that text. In dos & windows the line ends with a cr lf pair, which would be ascii 13 & 10. The 12 would be an ascii ff, so I cannot envision what actually placed the "12"s throughout your post.

I simply highlighted the text with the mouse cursor and then chose Copy from the contextual menu. I agree it’s not a matter of cr+lf. I only supposed that could be something to identify an SO running from an external disk, because inxi is a command that goes deep in the system hardware.

Ok, both workarounds do work, but the necessary figures differ from those suggested with my configuration. The best strings in my case are:
QT_QPA_PLATFORM=xcb QT_SCALE_FACTOR=1.2 libreoffice --writer
SAL_FORCEDPI=220 libreoffice --writer

Can anyone suggest me how to create an alias of the libreoffice command integratig such strings?
I don’t think that a bash script will do the job and it is a very long time that I don’t write a line of code. At the time my preferred languages were QuickBasic, Fortran 5 and 6502 Assembler. Something a bit obsolete nowadays, I’m afraid…

1 Like

You could go to /usr/share/applications/ directory and find libreoffice-writer.desktop.

Open and find all line with Exec=. Usually file *.desktop have more than one Exec= and for libreoffice-writer.desktop it have 2 line with Exec=.

Edit the line add pass the environtment variable. For example:

# Pass `env VARIABLES`.
Exec=env SAL_FORCEDPI=220 libreoffice --writer %U
# And at very bottom line
Exec=env SAL_FORCEDPI=220 libreoffice --writer

If after editing *.desktop the icon gone, try to logout and login again. Now each time we click the icon, it will uses the env we set inside the *.desktop launcher file.

I think the “12” happens when you let PackageKit find and install the command you requested. At least it did when I ran the inxi command and it wasn’t installed. After installation of inxi and I ran it again I see section headers in blue and bold instead of “12” at the beginning of each section.