/lib64/libpthread.so.0: version `GLIBC_PRIVATE' not found


I had installed a software in my fedora, when I run it , then report:

/lib64/libpthread.so.0: version `GLIBC_PRIVATE’ not found

how to resovle it?

What is the software and what installation method did you use?
Perhaps the software binary is not compatible with the current Fedora release.
You may need to specify a custom LD_LIBRARY_PATH in the app launcher.

synopsys software, which is a IC software, installed by synopsys`s installer.
how to resolve?

I just checked /usr/lib64/libpthread.so.0 for GLIBC strings (up-to-date Fedora 37 as of about 24 hours ago) which yields:


Unless “GLIBC_PRIVATE” is being concatenated from components or the library is older or strings doesn’t find the encodings I checked for then I would assume you have a version built with a private libc

Is this the version you have:

-rwxr-xr-x. 1 root root 15904 Jan 11 05:14 /usr/lib64/libpthread.so.0
/usr/lib64/libpthread.so.0: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, BuildID[sha1]=622fcaae1f5e94890852b15a1705dff85830347b, for GNU/Linux 3.2.0, stripped


You could always try exporting GLIBC_PRIVATE=whatever version of libc is on your machine. You could also try setting GLIBC_PRIVATE to something then using strace to figure out what libpthread is trying to do with it (you’d probably need to run before and after setting the environment variable to figure out at what point the code quits). Also try running the app either from a terminal or in gdb - there may be extra info that could clue you in as to what’s going wrong.

there may be info available via journalctl too

I don`t understand, my glibc is same with you, no GLIBC_PRIVATE in my fedora.

have you tried just running your app from a terminal - there may be some info written to stdout.

Check if you can find any strings related to your app using journalctl - just grep the entire output for syopsys e.g. (journalctl | grep -i synopsys)

You need more info. I did find something related on stack overflow but it wasn’t super helpful.

I think the best thing to do is contact synapsys technical support. I’m not seeing any products that are free to download and play around with.

I am not familiar with specific Synopsys software, but most likely it does not support Fedora. Check the product’s documentation for supported platforms. You can try running it in a container (e.g. using toolbox) or VM with a supported platform (likely RHEL/CentOS 7 or 8).