Last update broke Blender

On Fedora 35 using KDE Plasma.

After my last dnf update, several packages were upgraded. I tried opening up a project in Blender 3 and it caused every window I had open to start stretching out like crazy all over my monitors. Resetting my PC made everything go back to normal, but I can’t open a project in Blender without it happening again. It also caused my Latte dock to no longer load.

I’ve tried re-installing both, but it did not fix the issue. I also tried undoing the update using dnf history undo and dnf history rollback but neither worked due to KeyError: 'Reason Change'

The issue also occurs on both Wayland and X11. Also tried booting into an older kernal version, so I’m guessing it isn’t that.

I noticed several mesa package upgrades, so it might be that. I’m not sure if there’s a simple way to revert it to the last version installed.

Make uninstall blender and try reinstalling if it still doesn’t resolve that issue and as you have told you tried with hostory undo method and that doesn’t work i think i should work but it is okey you can try with flatpak or snap version of that app and if it works fine.
For flatpak

flatpak install flathub org.blender.Blender

For snap

sudo snap install blender --classic
1 Like

Hi, yeah I had tried uninstalling and re-installing through Discover, but still ran into the issue. I’ve tried through flatpak as you suggested and it seems to run fine now!

Do you have any idea what could have caused it? I’m assuming mesa update, but there were many packages that got updated.

Thanks for your help!

Btw i forgot to welcome you in this ask :fedora: community.
I can’t give you the actual reason there could be lots of potential point for failure but i think it might be caused because some of your system dependence updated with system update so it caused some issues this type of issues happen but resolves with in 7-10 days as that software vendor update there application and which solves that issue.
To provide much more details we need more info but if you want that app to work just want some time until blender provide a new update hope to solve that conflict issue.