Blender UI broken, Substance Painter, 3d Coat | Fedora 40 | AMD GPU


So one of last Fedora (F40) updates broke blender - whole UI in 4.1.1 lost its icons in UI, Flatpak/Snap works fine but both of them are unable to turn on AMD GPU acceleration - HiP, so blender flatpak/snap is out of equation. Only AppImage or Fedora repo.

I hve also Substance Painter older version 6.2.2 Linux release installed from rpm, it worked, now it just crashes (repeatedly hundreds of times till I kill it).

3DCoat AppImage, works ok’ish, but there is odd bug also with UI Icons, they are visible only in some proximity of the cursor. However, I have to check that maybe there is new 3DCoat build for Ubuntu 24.04 already, cause the one I am using is build on the previous LTS.

I will investigate it whole stuff more today after the work, and post results below if any.
I have my suspicions - yea Wayland looking at you, :expressionless:

NGL I am kind of tired already of this :smiley: , I had no problem after ditching Windows for F40, but this, I didn’t have such random events on a W…

Any help with solving this issues will be very appreciated, I am quite advanced in computers but fresh guy in linux.
I know I have to try to run them via terminal to get some logs, and probably try to solve some lib dependencies that were updated in last F40 update. But I know I will fail at this task :smiley:
I really don’t want to go back to windows…

Thanks for understanding and any help!

I guessed containers will kind of solve this issues at last for 3DCoat and Substance?
Silverblue(Atomic) will do here any difference, I kind of understand the idea, but situation will be similar? Except going back to previous version will be easier?

If you are on Blender Flatpak, you can point to a different commit, and mask the update until you feel comfortable to upgrade.

There is the Github commits, You can also check through flatpak as well.

flatpak remote-info --log flathub org.blender.Blender will bring up the commit history

Here is an example of things you can do :

I’ve never used this software so i do not know. Although we can check logs and see why it is crashing. Also try starting it from the terminal to see what error messages come up.

I kind of think flatpak is more versitile in going back to a previous release as it is commit based updates.

1 Like

Thanks will take a look into that, but the blender here is not a problem, update of fedora caused this bugs in blender, and other software :slight_smile:

What in Fedora caused the AMD GPU’s to not recognize HIP or ROCm packages in Blender?

:arrow_up: This is the bug in blender, after latest Fedora update, “missing icons in whole UI” - not HIP issue.

As you can see, no icons (ok except toolbar on the left) and even picture on a welcome popup is missing.

Now about HIP.
Hip not working in Flatpak release of blender is a different story, and it is the reason why I do not use flatpak blender. Because I need GPU acceleration in blender on AMD GPU. HIP for now works only when you have AppImage or blender from repository, and to work in flatpak version probably need a blender dev or AMD intervention, it is about driver privileges or something not about package itself.

And despite information that blender flatpak is provided and maintained by Blender Foundation, it is not, it just a name. Blender foundation only provides snap, and AppImage.

1 Like

That is unfortunate, I have both AMD and Nvidia systems and have not experienced this. . .

Yes, I am fully aware of the convoluted ways to get Blender working properly in the flatpak, and yes it is community built. I have a watercooler here for Blender specific stuff if you ever want to drop by :

1 Like

Well, I’ve made a test, use Timeshift, and go back for backup from Sunday and yes, blender 4.1.1 is working fine, so something in Fedora Update broke it.

Substance Painter is not working, it is old program and not going well with Wayland, even QT_QPA_PLATFORM=xcb don’t change a thing, and around F40 release it was working, maybe after upgrade to Plasma 6.1 it stopped… well. Shame, but I can always try it to install it in wine.

3DCoat is the same, so it is a feature not a bug, it is just weird, so I thought it might be related.

So that Watercooler is what, it is a manifest to force blender foundation to properly make a flatpak build? I have to say that I am 100% sure I understand what it is about :slight_smile:

Yup, to be sure I installed update again for the system ~700mb, restart and my blender 4.1.1 don’t have icons in the UI…:expressionless:

Problem with blender solved, but 50/50 way, snap with blender 4.1.1 works well, no bug with missing icons caused by Fedora Update, and HiP is working as far as I can say.

As this is Silverblue, the output of rpm-ostree status and rpm-ostree db diff between the deployment that worked and the one that doesn’t would help diagnose this issue.

1 Like

It is not Silverblue, it is regular F40 on Plasma.

I asked if this issue will be also on Silverblue, or in container. As a potential solution fopr this issue, I can move to Silverblue from F40 or make container with whatever distro I need to use to have it work without problems.

I have the same issue of missing icons in Blender. I’m running a Fedora Atomic system and my previous deployment was working. I use hyprland. AFAICT HIP/ROCm is functional in the broken blender with missing icons. Flatpak Blender has icons.

~ $ rpm-ostree status
State: idle
AutomaticUpdates: stage; rpm-ostreed-automatic.timer: no runs since boot
                   Digest: sha256:baf0b1d1c9b20bbf848b32e69db1d7495bddbd7078dbca45cf1a5953bbcbd6c5
                  Version: 40.20240624.0 (2024-06-24T17:10:09Z)
                     Diff: 37 upgraded, 2 added
          LayeredPackages: calf libvirt libvirt-daemon-config-network libvirt-daemon-kvm lzip qemu-kvm rocm-hip
                           rocm-hip-devel rocm-opencl rocm-opencl-devel rocm-runtime rocm-runtime-devel virt-install
                           virt-manager xdg-desktop-portal-hyprland xrandr zsh

● ostree-image-signed:docker://
                   Digest: sha256:32d3e293d089c574887ac6e7bbacb045f5114790064b5ae7560e20a1dce59d15
                  Version: 40.20240621.0 (2024-06-22T17:08:59Z)
          LayeredPackages: libvirt libvirt-daemon-config-network libvirt-daemon-kvm lzip qemu-kvm rocm-hip rocm-hip-devel
                           rocm-opencl rocm-opencl-devel rocm-runtime rocm-runtime-devel virt-install virt-manager
                           xdg-desktop-portal-hyprland xrandr zsh
~ $ rpm-ostree db diff
ostree diff commit from: booted deployment (53693579efe033436b6835642c8e5ee16e7c9c9731e79586f92e5fcad2946445)
ostree diff commit to:   pending deployment (5cd730198a5e6f0789aa988534544a94301fa0183e829bfda9166b2ac34b1d89)
  OpenImageIO ->
  cpp 14.1.1-5.fc40 -> 14.1.1-6.fc40
  fribidi 1.0.13-4.fc40 -> 1.0.14-2.fc40
  gcc 14.1.1-5.fc40 -> 14.1.1-6.fc40
  gcc-c++ 14.1.1-5.fc40 -> 14.1.1-6.fc40
  kernel 6.9.4-200.fc40 -> 6.9.5-200.fc40
  kernel-core 6.9.4-200.fc40 -> 6.9.5-200.fc40
  kernel-modules 6.9.4-200.fc40 -> 6.9.5-200.fc40
  kernel-modules-core 6.9.4-200.fc40 -> 6.9.5-200.fc40
  kernel-modules-extra 6.9.4-200.fc40 -> 6.9.5-200.fc40
  kernel-tools 6.9.4-200.fc40 -> 6.9.5-200.fc40
  kernel-tools-libs 6.9.4-200.fc40 -> 6.9.5-200.fc40
  libatomic 14.1.1-5.fc40 -> 14.1.1-6.fc40
  libgcc 14.1.1-5.fc40 -> 14.1.1-6.fc40
  libgfortran 14.1.1-5.fc40 -> 14.1.1-6.fc40
  libgomp 14.1.1-5.fc40 -> 14.1.1-6.fc40
  libldb 2.9.0-1.fc40 -> 2.9.1-1.fc40
  libquadmath 14.1.1-5.fc40 -> 14.1.1-6.fc40
  libsmbclient 2:4.20.1-1.fc40 -> 2:4.20.2-1.fc40
  libstdc++ 14.1.1-5.fc40 -> 14.1.1-6.fc40
  libstdc++-devel 14.1.1-5.fc40 -> 14.1.1-6.fc40
  libwbclient 2:4.20.1-1.fc40 -> 2:4.20.2-1.fc40
  libxslt 1.1.40-1.fc40 -> 1.1.41-1.fc40
  mesa-dri-drivers 24.1.1-5.fc40 -> 24.1.2-2.fc40
  mesa-filesystem 24.1.1-5.fc40 -> 24.1.2-2.fc40
  mesa-libEGL 24.1.1-5.fc40 -> 24.1.2-2.fc40
  mesa-libGL 24.1.1-5.fc40 -> 24.1.2-2.fc40
  mesa-libgbm 24.1.1-5.fc40 -> 24.1.2-2.fc40
  mesa-libglapi 24.1.1-5.fc40 -> 24.1.2-2.fc40
  mesa-va-drivers-freeworld 24.1.1-1.fc40 -> 24.1.2-1.fc40
  mesa-vulkan-drivers 24.1.1-5.fc40 -> 24.1.2-2.fc40
  ptex-libs 2.4.2-5.fc40 -> 2.4.3-1.fc40
  python3-openimageio ->
  samba-client 2:4.20.1-1.fc40 -> 2:4.20.2-1.fc40
  samba-client-libs 2:4.20.1-1.fc40 -> 2:4.20.2-1.fc40
  samba-common 2:4.20.1-1.fc40 -> 2:4.20.2-1.fc40
  samba-common-libs 2:4.20.1-1.fc40 -> 2:4.20.2-1.fc40

Note that I’m using a custom Atomic Fedora build (based off wayblue).

1 Like

You don’t need Silverblue to run containers. You can use Podman/toolbox on F40. I would stay away from that workflow for now, because getting AMD to use the containers is a little. . . finicky.

@slizgi Can you post inxi -Fzxx for us please?

There are other AMD users experiencing Blender issues. Also, what version of Mesa are you on?

1 Like

Removed wayland

Sure thing!
This what I’ve got from inxi:

  Kernel: 6.9.5-200.fc40.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.41-37.fc40
  Desktop: KDE Plasma v: 6.1.0 tk: Qt v: N/A wm: kwin_wayland dm: SDDM
    Distro: Fedora Linux 40 (KDE Plasma)
  Type: Desktop Mobo: Micro-Star model: MEG X570 UNIFY (MS-7C35) v: 2.0
    serial: <superuser required> UEFI: American Megatrends LLC. v: A.H0
    date: 06/28/2023
  Info: 12-core model: AMD Ryzen 9 3900X bits: 64 type: MT MCP arch: Zen 2
    rev: 0 cache: L1: 768 KiB L2: 6 MiB L3: 64 MiB
  Speed (MHz): avg: 2351 high: 4324 min/max: 2200/4672 boost: enabled cores:
    1: 2200 2: 2200 3: 2200 4: 2200 5: 2202 6: 2200 7: 2200 8: 2200 9: 2200
    10: 2161 11: 2200 12: 2200 13: 3800 14: 2200 15: 2200 16: 2200 17: 2200
    18: 2200 19: 2200 20: 2200 21: 2176 22: 2162 23: 2200 24: 4324
    bogomips: 182393
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: AMD Navi 21 [Radeon RX 6800/6800 XT / 6900 XT]
    vendor: Tul / PowerColor driver: amdgpu v: kernel arch: RDNA-2 pcie:
    speed: 16 GT/s lanes: 16 ports: active: DP-1,DP-3
    empty: DP-2,HDMI-A-1,Writeback-1 bus-ID: 2f:00.0 chip-ID: 1002:73bf
  Display: wayland server: v: 1.20.14 with: Xwayland v: 24.1.0
    compositor: kwin_wayland driver: X: loaded: amdgpu
    unloaded: fbdev,modesetting,radeon,vesa dri: radeonsi gpu: amdgpu
    d-rect: 4640x3360 display-ID: 0
  Monitor-1: DP-1 pos: bottom-l res: 3440x1440 size: N/A
  Monitor-2: DP-3 pos: top-right res: 1200x1920 size: N/A
  API: EGL v: 1.5 platforms: device: 0 drv: radeonsi device: 1 drv: swrast
    surfaceless: drv: radeonsi wayland: drv: radeonsi x11: drv: radeonsi
    inactive: gbm
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.1.2 glx-v: 1.4
    direct-render: yes renderer: AMD Radeon RX 6800 XT (radeonsi navi21 LLVM
    18.1.6 DRM 3.57 6.9.5-200.fc40.x86_64) device-ID: 1002:73bf
    display-ID: :0.0
  API: Vulkan v: 1.3.283 surfaces: xcb,xlib,wayland device: 0
    type: discrete-gpu driver: N/A device-ID: 1002:73bf device: 1 type: cpu
    driver: N/A device-ID: 10005:0000
  Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie:
    speed: 16 GT/s lanes: 16 bus-ID: 2f:00.1 chip-ID: 1002:ab28
  Device-2: Creative SB Omni Surround 5.1
    driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 1.1 speed: 12 Mb/s
    lanes: 1 bus-ID: 1-2:2 chip-ID: 041e:322c
  API: ALSA v: k6.9.5-200.fc40.x86_64 status: kernel-api
  Server-1: PipeWire v: 1.0.7 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin
  Device-1: Realtek RTL8125 2.5GbE vendor: Micro-Star MSI driver: r8169
    v: kernel pcie: speed: 5 GT/s lanes: 1 port: f000 bus-ID: 27:00.0
    chip-ID: 10ec:8125
  IF: enp39s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie:
    speed: 5 GT/s lanes: 1 bus-ID: 28:00.0 chip-ID: 8086:2723
  IF: wlo1 state: down mac: <filter>
  Device-1: Intel AX200 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 bus-ID: 1-4:3 chip-ID: 8087:0029
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.2
    lmp-v: 11
  Local Storage: total: 11.41 TiB used: 2.88 TiB (25.2%)
  ID-1: /dev/nvme0n1 vendor: Western Digital model: WD BLACK SN850X 1000GB
    size: 931.51 GiB speed: 63.2 Gb/s lanes: 4 serial: <filter> temp: 52.9 C
  ID-2: /dev/nvme1n1 vendor: Samsung model: SSD 970 EVO Plus 1TB
    size: 931.51 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> temp: 43.9 C
  ID-3: /dev/nvme2n1 vendor: A-Data model: SX8200PNP size: 1.86 TiB
    speed: 31.6 Gb/s lanes: 4 serial: <filter> temp: 38.9 C
  ID-4: /dev/sda vendor: Samsung model: SSD 850 EVO 500GB size: 465.76 GiB
    speed: 6.0 Gb/s serial: <filter>
  ID-5: /dev/sdb vendor: Samsung model: SSD 870 EVO 2TB size: 1.82 TiB
    speed: 6.0 Gb/s serial: <filter>
  ID-6: /dev/sdc vendor: Western Digital model: WD20EURX-63T0FY0
    size: 1.82 TiB type: USB rev: 3.1 spd: 10 Gb/s lanes: 1 serial: <filter>
  ID-7: /dev/sdd vendor: Samsung model: SSD 870 QVO 4TB size: 3.64 TiB
    type: USB rev: 3.1 spd: 10 Gb/s lanes: 1 serial: <filter>
  ID-1: / size: 250.1 GiB used: 45.31 GiB (18.1%) fs: ext4 dev: /dev/nvme0n1p4
  ID-2: /boot size: 1.9 GiB used: 338.3 MiB (17.4%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-3: /boot/efi size: 1022 MiB used: 19 MiB (1.9%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-4: /home size: 661.71 GiB used: 197.17 GiB (29.8%) fs: ext4
    dev: /dev/nvme0n1p3
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 48.0 C mobo: N/A gpu: amdgpu temp: 58.0 C
    mem: 50.0 C
  Fan Speeds (rpm): N/A gpu: amdgpu fan: 1210
  Memory: total: 128 GiB note: est. available: 125.7 GiB used: 8.69 GiB (6.9%)
  Processes: 557 Power: uptime: 3h 15m wakeups: 0 Init: systemd v: 255
    target: graphical (5) default: graphical
  Packages: 65 pm: flatpak pkgs: 54 pm: snap pkgs: 11 Compilers: clang: 17
    gcc: 14.1.1 Shell: Bash v: 5.2.26 running-in: konsole inxi: 3.3.34

And about Mesa, below is everything from vulcaninfo:


Vulkan Instance Version: 1.3.283

Instance Extensions: count = 24
VK_EXT_acquire_drm_display             : extension revision 1
VK_EXT_acquire_xlib_display            : extension revision 1
VK_EXT_debug_report                    : extension revision 10
VK_EXT_debug_utils                     : extension revision 2
VK_EXT_direct_mode_display             : extension revision 1
VK_EXT_display_surface_counter         : extension revision 1
VK_EXT_headless_surface                : extension revision 1
VK_EXT_surface_maintenance1            : extension revision 1
VK_EXT_swapchain_colorspace            : extension revision 4
VK_KHR_device_group_creation           : extension revision 1
VK_KHR_display                         : extension revision 23
VK_KHR_external_fence_capabilities     : extension revision 1
VK_KHR_external_memory_capabilities    : extension revision 1
VK_KHR_external_semaphore_capabilities : extension revision 1
VK_KHR_get_display_properties2         : extension revision 1
VK_KHR_get_physical_device_properties2 : extension revision 2
VK_KHR_get_surface_capabilities2       : extension revision 1
VK_KHR_portability_enumeration         : extension revision 1
VK_KHR_surface                         : extension revision 25
VK_KHR_surface_protected_capabilities  : extension revision 1
VK_KHR_wayland_surface                 : extension revision 6
VK_KHR_xcb_surface                     : extension revision 6
VK_KHR_xlib_surface                    : extension revision 6
VK_LUNARG_direct_driver_loading        : extension revision 1

Instance Layers: count = 2
VK_LAYER_FROG_gamescope_wsi_x86_64 Gamescope WSI (XWayland Bypass) Layer (x86_64) 1.3.221  version 1
VK_LAYER_MESA_device_select        Linux device selection layer                   1.3.211  version 1

        apiVersion         = 1.3.278
        driverVersion      = 24.1.2
        vendorID           = 0x1002
        deviceID           = 0x73bf
        deviceType         = PHYSICAL_DEVICE_TYPE_DISCRETE_GPU
        deviceName         = AMD Radeon RX 6800 XT (RADV NAVI21)
        driverID           = DRIVER_ID_MESA_RADV
        driverName         = radv
        driverInfo         = Mesa 24.1.2
        conformanceVersion =
        deviceUUID         = 00000000-2f00-0000-0000-000000000000
        driverUUID         = 414d442d-4d45-5341-2d44-525600000000
        apiVersion         = 1.3.278
        driverVersion      = 0.0.1
        vendorID           = 0x10005
        deviceID           = 0x0000
        deviceType         = PHYSICAL_DEVICE_TYPE_CPU
        deviceName         = llvmpipe (LLVM 18.1.6, 256 bits)
        driverID           = DRIVER_ID_MESA_LLVMPIPE
        driverName         = llvmpipe
        driverInfo         = Mesa 24.1.2 (LLVM 18.1.6)
        conformanceVersion =
        deviceUUID         = 6d657361-3234-2e31-2e32-000000000000
        driverUUID         = 6c6c766d-7069-7065-5555-494400000000

And for Substance Painter I think I will try to run it in distrobox, on a proper RHEL/Centos or something, all dependencies should be fine there, just forever. Heck, maybe even Substance Designer will work that way. I just need to learn it because I have no idea how :slight_smile: I am still Linux noob :wink:

1 Like

I just move to snap in matter of blender, already have snap as a sidekick to just have VCode from official channel. And blender from snap, have icons, and HiP is working, so win~win, just not from regular repo, what is fine I guess.
But I have to admit with all that different channels of distribution on Linux, it is a bigger mess system/files wise than on Windows in my opinion :smiley:


It’s a strange time for Linux packaging. Maybe in a year or two it will flatten out.

Most people are experiencing issues with the latest Mesa, so that could be the problem. Not sure though. Just piecing issues.

1 Like

Alright, will do test today after work, with just downgrading the mesa, ale take look if icons go back to blender :slight_smile: Thanks for the tip!

I also think about putting blender in distrobox, because to have HiP, it needs a Radeon Pro drivers, and if I am correct they are having worse performance in games than the regular one. And I sometimes play, so.

I have to figure it out, still Linux is fairly fresh to me, but I am not missing Windows, maybe it was more straightforward and for sure have a better support for pro apps from big companies. I would be super happy if Affinity notice Linux and release trio apps on it.
But dolphin is like 10x faster and snappier than explorer, in w10 it is ok’ish, but in W11 explorer is just artificially slow.

1 Like

Long story short, I tried to downgrade mesa, it worked, except one stubborn i686 package (probably from wine or lutris for 32 bit games), so I made something stupid and removed it, and then my whole Plasma died, black screen after reboot. But it is fine, I restored the system from timeshift again :slight_smile:

So my test was inconclusive, because after downgrading all of them, except that one, I was seeing that all packages were 24.0.5, but vulcaninfo was still showing 24.1.2 so I guess downgrade was not successful.

1 Like

it happens. . . You should be able to downgrade all the packages or even revert the update. I don’t want to bombard you with information but dnf history can be real helpful in rolling back issues.

hey, for anyone still facing this issue. Simply downgrade OpenImageIO.
sudo dnf downgrade -y OpenImageIO

This got the UI working as before on my fedora 40 rig.