Darktable Flatpak no GPU/OpenCL support

not sure what i am missing on here Silverblue 39 darktable flatpka, but cant seem to get GPU onboard or enable OpenCL stuff on flatpak have been trying ot check Flatseal for permissions.

Blender, Inkscape and Gimp all works and supports GPU on flatpaks so that side is all good only the Darktable is what i need or if it just dosent suppport on flatpak side need to find other alternative

Sometimes I am also using Darktable and Blender on Silverblue 39. I just checked if it is using GPU by running command in terminal:
And it is running within GPU. I do not know why yours not running most probably drivers. Darktable not using wayland do you have xorg installed? Try Rawtherapy it is also very good program just do not have masks in every module.
P.S. if nvidia-smi is runing on your computer’s terminal then you have xorg installed if not you need to install it.

I have Nvidia enabled on other apps as said those rendering is working using Nvidia dgpu. I need to check again flatpak permissions if there is something I missed

You tried to use: nvidia-smi?
Rawtherapy can run only on wayland.

I know I have Nvidia working that is not problem since other apps works and use dGPU as rendering only something I’m missing on Darktable fkatpak settings I know it works with openCL since I had it working on RPM using workstation

Fixed the problem

well seems like default Flatpak most cases are fedora Linux and those files seems to be old in this case 7 Months old as it points Fedora Linux Flatpak version vas 4.4 and latest Flathub version 4.6.1 with added OpenCL by default on startup and other stuff.

i guess default Flatpak should be Flathub on everything not just Fedora Linux

On most of these thing, you need to have the Flathub Flatpak, Although I’m not sure why the Fedora Flatpak does not ship OpenCL/GL support ??? I understand not shipping proprietary codecs but not OpenCL/GL stuff.