Laptop does not show Luks password prompt as nvme fails with kernel-6.4.11 & kernel-6.4.12

Hello there,

my system fails to show the LUKS password prompt with the kernels kernel-6.4.11 & kernel-6.4.12.
It works fine with kernel-6.4.9.

The logs show, that nvme is complaining.

Any idea what could go wrong here and how I can further investigate this? Not sure how to proceed and where to file a bug…

Best regards

Now I found a bug tracker… I think this is the relevant bug entry: 217802 – regression NVME failure in 6.4.11 : 6.4.10 works fine.

@neongreeneggplant Can you try the workaround mentioned here? I.e. press F8 after laptop start, in the grub menu press e to edit the current boot option, add nvme_core.default_ps_max_latency_us=0 pcie_aspm=off at the end of the linux line (it’s also good to remove rhgb quiet), and press ctrl+x to boot. Does it boot this way even with the latest kernels?

1 Like

This problem is also tracked here:

1 Like

Thanks for this link!

I am having this provlem on a Dell Precision 5520 (system is also mentioned in the link as affected devices).

The solution for me was to edit the grub setting and add: nvme_core.default_ps_max_latency_us=0 pcie_aspm=off.
This allowed me to boot and access the system. Then I blacklisted the kernel modules for the realtek card reader…

sudo cat /etc/modprobe.d/rtsx-blacklist.conf
blacklist rtsx_pci
blacklist rtsx_pci_sdmmc

and rebuild the initramfss with dracut.

From then on, I could work with kernel 6.4.13.

Thanks for your confirmation.

Somehow I did not realize that you have sent two messages. But I guess I answered it nevertheless… :sweat_smile:

Thanks both :+1: Was struggling with this issue for weeks since upgrading from 6.4.4 → 6.4.11

Dell XPS 15 9560, with the Realtek card reader mentioned in

Followed the advice above; added nvme_core.default_ps_max_latency_us=0 pcie_aspm=off to grub config, worked first go.

Haven’t rebuilt initramfs or blacklisted kernel mods yet. Literally just booted into 6.4.15 for the first time after weeks of avoiding reboots. Much appreciated :clap: