LUKS disk not detected

Whilst dealing with Problems caused by resume from sleep I thought I’d work around the problem by editing /etc/systemd/logind.conf to set it to ignore the laptop’s lid being closed. After doing this and restarting systemd-logind the system needed rebooting.

But, at that point, after going through the GRUB menu’s kernel selection the LUKS disk timed out; a password prompt never appeaed and I ended up at a rescue prompt.

I’ve tried booting from a live USB but can’t see the relevant disk in order to try decrypting and viewing it. lsblk shows this:

loop0         7:0    0  1.9G  1 loop 
loop1         7:1    0  7.6G  1 loop 
├─live-rw   253:0    0  7.6G  0 dm   /
└─live-base 253:1    0  7.6G  1 dm   
loop2         7:2    0   32G  0 loop 
└─live-rw   253:0    0  7.6G  0 dm   /
sda           8:0    1  7.3G  0 disk 
├─sda1        8:1    1  1.9G  0 part /run/initramfs/live
├─sda2        8:2    1 11.6M  0 part 
└─sda3        8:3    1  300K  0 part 
zram0       252:0    0    8G  0 disk [SWAP]

There should be a 500GB NVMe disk present.
I’ve tried using cryptsetup luksOpen on the /dev/sda* partitions but it reports that they’re not valid LUKS devices.

Presumably, as the GRUB menu appears and the system starts booting it’s not a complete failure of the NVMe disk. But, at this point I am rather perplexed and would welcome any suggestions.

This one has finally been solved.
I recalled when installing Fedora on this laptop that it was necessary to change the disk mode from RAID to AHCI for Linux to be able to access it. That setting had been put back to the default, presumably due to a firmware update.