LUKS cryptsetup error on each reboot/shutdown

I have my system set up with LVM on LUKS. On every reboot or shutdown, journalctl shows this error:

systemd-cryptsetup: Device luks-[UUID] is still in use.
systemd-cryptsetup: Failed to deactivate: Device or resource busy


NAME                                          MAJ:MIN RM  SIZE RO TYPE  MOUNTPOINT
sda                                             8:0    0  1.9T  0 disk  
├─sda1                                          8:1    0  200M  0 part  /boot/efi
├─sda2                                          8:2    0    1G  0 part  /boot
└─sda3                                          8:3    0  1.9T  0 part  
  └─luks-[UUID]                               253:0    0  1.9T  0 crypt 
    ├─[MACHINE]-root                          253:1    0   50G  0 lvm   /
    ├─[MACHINE]-data                          253:2    0    1T  0 lvm   /media/data
    ├─[MACHINE]-home                          253:3    0  100G  0 lvm   /home
    └─[MACHINE]-swap                          253:4    0    4G  0 lvm   [SWAP]


luks-[UUID] UUID=[UUID] none discard


/dev/mapper/[MACHINE]-root /                       ext4    defaults,x-systemd.device-timeout=0 1 1
UUID=[BOOT-UUID] /boot                             ext4    defaults        1 2
UUID=[BOOT-EFI-UUID]       /boot/efi               vfat    umask=0077,shortname=winnt 0 2
/dev/mapper/[MACHINE]-home /home                   ext4    defaults,x-systemd.device-timeout=0 1 2
/dev/mapper/[MACHINE]-data /media/data             ext4    defaults,x-systemd.device-timeout=0 1 2
#/swapfile		 none			swap	defaults	0 0
/dev/mapper/[MACHINE]-swap none                    swap    defaults,x-systemd.device-timeout=0 0 0

It seems like I experience the same problem. I saw it when I tried to type my posting. Maybe I can just add it here? Lets see …

"With the procedure of reporting a bug I am not familiar yet. That’s why I want to ask you as community for some kind of review.

I setup the XFCE spin of Fedora 36 with the disk encryption option, but let it automatically do the partitioning (/ and /home as btrfs). Then I ran the updates.

The reboots and shutdowns take more time now.

With journalctl I was not able to dig up a lot of information. One hint is about cryptsetup that gets a 90 seconds timeout kill, because the device is still in use so the luks container cant be deactivated.

(thats too vague for a BR, right?)

My installations from about 7-10 days ago and before that did not show this behavior. It’s no problem to wait for the timeout. I would like to use this situation to learn and hope you teach me, how to gather more details.