Boot error and can't access LUKS Encrypted Fedora 37 drive (potentially corrupted OS drive)

Hey Fedora community, I’ve recently hit a bit of a brick wall with a problem and unfortunately I’m a bit of a linux newbie and only been using linux for just over 2 months so I need a bit of help here.

Problem: my laptop won’t boot past the section past the encryption password and I can’t access my files even through a live-cd version of fedora.

Honestly at this rate I just want to be able to get my written journal off the drive and I’m happy to reinstall the whole operating system and start again if I have to. (sadly I have no backups because I’ve only just started learning how fedora linux works)

Details:
When booting up fedora workstation 37 or any other previous fedora 36 version from the grub menu (including the rescue version). I’m greeted with the regular password for my encryption code. I put it in and fedora starts loading up, I press the ESC key to see more details I noticed it gets stuck at:

[  OK  ] Reached target sysinit.target - System Initialization.
[  OK  ] Reached target basic.target - Basic System.

Which doesn’t seem very far considering how many usually show up. Not too long after it starts throwing a reoccurring error. (I am aware I’m somewhat doxing my system here but I really just want this fixed at this point)

dracut-initqueue[428]: Warning: /lib/dracut/hooks/initqueue/finished/devexits-\x2fdev\x2fdisk\x2fby-uuid\x2f2ac7a509-7dac-42ea-b892-abd3e094a65a.sh: "if ! grep -q After=remote-fs-pre.target /run/systemd/generator/systemd-cryptsetup@*.service 2>/dev/null; then
dracut-initqueue[428]:  [  -e "/dev/disk/by-uuid/2ac7a509-7dac-42ea-b892-adb3e094a65a" ]
dracut-initqueue[428]:  fi"
dracut-initqueue[428]: Warning: dracut-initqueue: starting timeout scripts
dracut-initqueue[428]: Warning: dracut-initqueue: timeout, still waiting for following initqueue hooks:
dracut-initqueue[428]: Warning: /lib/dracut/hooks/initqueue/finished/90-crypt.sh: "[ -e /dev/disk/by-id/dm-uuid-CRYPT-LUKS?-*3245cc27b0df4b42bf96f5367d312bf3*-*] || exit 1

This usually goes for about 2 minutes until it gives up generates a “/run/initramfs/rdsosreport.text”

and enters emergency mode. After that it says enter maintenance mode or continue. If I continue it says
Not all disks have been found
You might want to regenerate your initramfs.

Through research I’ve tried doing that through a live-cd (or usb, whatever it is aha) but I’m not sure if it only regenerated the initramfs with the live-cd version and not the main version.

In the live-cd version I’ve tried to mount the drive through the file manager by going → other location → fedora drive (yes it is the right one)
it gets me to put in the authentication code and errors saying that the drive won’t mount because it’s already mounted or busy. Then it disappears from the list entirely??

I’ve also tried mounting the drive ‘Disks’ and it works the same way with authentication but without erroring, however the unencrypted disk partition says “Contents Unknown” so I’m stuck again. I did manage one thing through the ‘Disk’ application. I managed to change the password to ‘1’ to make it easier for me which I knew was a risk but it also showed me that the encryption isn’t faulty it’s most likely the drive contents itself.

I’ve tried mounting it through the terminal with many commands on the internet but whenever I try to gain access it says “permission denied” so if someone has the correct commands that would be greatly appreciated.

I also tried using fsck commands that effect all drives and other ones that I can’t remember the name of with a BCS or something but I had no luck(s hehehe) with that because I’m really new to this and I really feel like I’ve been thrown into the deep end with this issue.

I’ve taken screenshots of the errors from the log files which I’ll have uploaded as well if someone can figure those out.
https://drive.google.com/drive/folders/1hsTxoCe2EL1guVuKEKOzoJAatsQ4F0SR?usp=sharing
I’ll add more if needed :))

Thanks so much for anyone who tries, I just really want some of my documents back and I’ve learnt my lesson with backups ;-;

It might perhaps be a bit easier to look at the logs from the live USB, as that would not also be trying to boot in addition to trying to mount the disk, which makes the logs more complicated.

Had the same issue but only when enabling _netdev option on the root volume in /etc/crypttab.

It was resolved by using rd.luks.partuuidinstead ofrd.luks.uuidin kernel cmdline in/etc/default/grub` (then regenerate grub config).

For some reason the /dev/disk/by-id/dm-uuid-CRYPT-LUKS... device is not generated during early boot and blocks progress.

See also https://forums.gentoo.org/viewtopic-p-8684970.html , rd.luks.name doesn't work without systemd · Issue #1566 · dracutdevs/dracut · GitHub and 592686 – sys-kernel/dracut-044 problem with root device on luks volume?

I needed this to setup clevis. But it still hung at the same place because of failing on /dev/fedora-server/root which seems caused by the kernel option lvm.lv. After removing this option, the systemd target didn’t fail anymore. But still failed to decrypt volume automatically or manually.

So eventually I removed _netdev from both fstab and crypttab. And was ready to give up but turned out that once network is up, clevis unlocks the devices. So I brought everything back to the defaults (except the rd.neednet=1 kernel option so network would start).

Thought it can give some clue to whoever hits this issue.