No Luks Password Prompt on 5.18.13

After an upgrade from 5.18.11-200.fc36.x86_64 to 5.18.13-200.fc36.x86_64
My system does not prompt me the password to decrypt my drives at boot.
So I cannot boot to my system, it just display my motherboard logo (usually the password prompt is just under the logo).

I am currently still able to boot into 5.18.11 without any problems at all.

Similar problem than that post from 2019 which did not get any answer

My grub config (if it does anything to help) is

GRUB_CMDLINE_LINUX="rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 initcall_blacklist=simpledrm_platform_driver_init rhgb quiet rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 initcall_blacklist=simpledrm_platform_driver_init"

my drives are as such (if it helps):

sdb                                             8:16   0 447.1G  0 disk  
├─sdb1                                          8:17   0     1G  0 part  /boot
├─sdb2                                          8:18   0   512M  0 part  /boot/efi
└─sdb3                                          8:19   0 445.6G  0 part  
  └─luks 253:0    0 445.6G  0 crypt 
    ├─vgSSD450-Games                          253:1    0   400G  0 lvm   /mnt/games
    ├─vgSSD450-Fedora                         253:2    0    40G  0 lvm   /
    └─vgSSD450-Swap                           253:3    0   5.6G  0 lvm   
nvme0n1                                       259:0    0 232.9G  0 disk  
└─nvme0n1p1                                   259:1    0 232.9G  0 part  
  └─luks 253:4    0 232.9G  0 crypt /home/REDACTED

Any pointers (kind of new to linux) on what it could be? settings to check? something changed in the new kernel that make it not prompt for the LUKS password which result in the drive not being decrypted and so no boot.

Welcome to ask.:fedora:edora @tipioli

Please have a look here:

Check if this helps.

I have the same problem, using NVIDIA proprietary driver and kernel 5.18.13.
The system is actually able to boot, but the display turns off before the LUKS password. So you have to type the password without seeing the prompt, and the image only returns after the boot. For some reason, the system seems to output the image to the integrated graphics HDMI during boot, instead of the GPU.
Kernel 5.18.11 did not have this issue.
Virtual tty (Ctrl+Alt+Fn) are also not displayed with Nvidia graphics.

I have already tried to use each of the following kernel parameters, without any success: nvidia-drm.modeset=1, nvidia-drm.modeset=0, nomodeset, initcall_blacklist=simpledrm_platform_driver_init

Did you try this?

Lasse Pihlainenlaamanni


If you have nVidia GPU and integrated Intel GPU, goto UEFI setup. Look for the “iGPU Multi Monitoring” setting. Disable this setting if you dont have any monitors connected to the iGPU (motherboard display connectors).
Graphical LUKS password prompt will now appear after GRUB.

I tried disabling this option in UEFI, but it didn’t solve the issue.

My Integrated GPU is disabled, so the problem is not from it being enabled.

I can confirm that the system does boot, and the new kernel (or combo kernel/Driver, decide to output on a display which is not the one that is connected!

I only had video out once I actually logged into my session (I am not using a display manager to log in).

NVidia Driver: 515.57

So i decided to try something ‘stupid’.

UEFI Settings (I haven’t changed anything but decided to check them again):

  • Prefer PCI Graphics
  • IGPU Memory 32M
  • IGPU multi monitor: Disabled.

Boot to luks with the monitor connected to the NVIDIA graphic card
Disconnect the cable and connect it to the IGPU
I have output.

So somehow the new kernel decide to not follow the UEFI settings to prefer PCI graphics, nor to display to the cable that is connected (I only have one).

It’s extremely inconvenient I am not sure when I get the login prompt.

Sorry for spamming 3 messages in a row.

Here is the bios settings that I have managed to get the display to work.

  • Primary adapter: Prefer PCI Graphics
  • IGPU Memory: Auto
  • IGPU multi monitor: Disabled.

It took 2s to show the prompt. So it’s an OK workaround for now, but If I ever need that IGPU (quicksync, hdw acc), it will be a problem compared to the previous kernel.

1 Like