Kinoite, a KDE (and now XFCE) version of Fedora Silverblue

Should be fixed now!

1 Like

well I’ve got this error - Have I made a mistake?

thx @Siosm

Whoops again, should be fixed now!

can you maybe explain how you build this using your scripts ? Im trying to generate a plasma / nvidia / chrome / quassel custom image for my use. I did manage to walk through the steps to get it all on my laptop as of yesterday. now id like to create an iso from it.

If you are only building one variant, you don’t really need my scripts. Here are the steps to build your own variant:

# Clone the official config
git clone silverblue && cd silverblue
# Use the correct branch
git checkout f30
# Optionnal: pull my changes from
# git pull ...
# Copy the config to create your own (pick your favorite desktop, kinoite is KDE here)
cp fedora-kinoite.yaml fedora-variant.yaml
# Add packages and change names
$EDITOR fedora-variant.yaml
# Prepare repo & cache
mkdir -p repo cache && ostree --repo=repo init --mode=archive
# Build (compose) you own variant
sudo rpm-ostree compose tree --repo=repo --cachedir=cache fedora-variant.yaml
# Update summary file
ostree summary --repo=repo --update

Then, install the official Fedora Silverblue and switch to your own ref (you will have to serve the repo folder using a web server):

# Add an ostree remote
sudo ostree remote add myvariant
# Pin the currently deployed (and probably working) version
sudo ostree admin pin 0
# List refs from variant remote
sudo ostree remote refs myvariant
# Switch to your variant
sudo rpm-ostree rebase myvariant:fedora/30/x86_64/variant

I have not yet build an ISO from this but I don’t think you really need it unless you are planning on installing a lot of systems.

This is a summary. For more, see:


well… clarify something for me, installing silverblue dumps a ton or gnomish desktop and other items, if we install kinoite or other above it, does it factually remove the gnome cruft ? recovering the used space? or is gnomeish items still installed using disk space ?

Once you have switched your current ref to Kinoite and unpinned all GNOME based deployments, you should be able to run:

sudo rpm-ostree cleanup -b
sudo rpm-ostree cleanup -m
sudo rpm-ostree cleanup -p
sudo rpm-ostree cleanup -r

to remove all cached content and deployments thus freeing as much space as possible. Beware that this will leave you with no other deployments on your system so you better make sure the one you are currently using works properly.


Welcome @dingo007 :slight_smile:

If you are certain you want to remove all that data, you can combine all the options into one operation: sudo rpm-ostree cleanup -bprm

And in case you want to know what each flag does, the help is pretty good:

  -b, --base            Clear temporary files; will leave deployments unchanged
  -p, --pending         Remove pending deployment
  -r, --rollback        Remove rollback deployment
  -m, --repomd          Delete cached rpm repo metadata

A pending deployment is one that you will reboot into next, i.e. an upgraded deployment.

A rollback deployment is one that you would use rpm-ostree rollback to select for next boot.


I thought I followed the steps to install the deepin spin and I get and error. Any idea what I missed with the gpg key?

rpm-ostree rebase kinoite:fedora/30/x86_64/deepin

error: Commit c68c8fbbaa4ded68ab35ef0de25d2252c435fe64add1df81da499dce9d135ed1: GPG verification enabled, but no signatures found (use gpg-verify=false in remote config to disable)

@bassclef I’ve got the same error

I’m sorry. I though I had done this properly but apparently I missed something and I can not find what I did wrong right now. You may disable the GPG verification until I fix this issue. There is hardly any loss of security here since my repository is HTTPS only and hosted on my server, which you trust since you are pulling the update from me. I’ll post an update once the issue is resolved.

1 Like

Understood and I appreciate it. Would it be best for me to manually enter gpg-verify=false in the config?

Im having a hell of a time downloading packages… failed 30 times so far… whats up

error: Cannot download Packages/l/libidn2-2.1.1a-1.fc30.x86_64.rpm: All mirrors were tried; Last error: Status code: 404 for

ok got through the download failures, can youu confirm your build process looks like this

This would have done it. But I’ve found and fixed the issue. Using GPG should be good now.

If I understand correctly, the mirror selection is distinct from the system dnf one thus sometimes you will get errors. I had some too but I have not found a way so far to select a specific known good mirror.

Looks good.


you’re probably working on the most important project 4sb - in terms of my taste. i make it official: imho, gnome 3 is unbearable and infinitely ugly (like it all came from a tomb). out-of-the-box & with tweaks.

all the best.

Thanks for the support but No thanks for the GNOME bashing. I started this to learn and to make any desktop available for Fedora Silverblue. I use both GNOME and KDE and I definitely appreciate all the work that goes into GNOME.


Can I use the silveblue installer to install Kinoite KDE instead or do I have to install silverblue and after that switch?

Yes, you should be able to use the Silverblue installer to directly install Kinoite. Unfortunately I don’t think there is any UI for doing it so you will have to either use a Kickstart config (see ostreesetup section) or do the install on the command line. I have not tested it myself but it should work. Please tell us if it works!