Kinoite, a KDE (and now XFCE) version of Fedora Silverblue

Yep very similar I am going to persevere see how things come along.

I have rebased to Silverblue Gnome is my second choice, but I need a system I can use and Silverblue is excellent and stable.

Hopefully it will not be long before we can test Kinoite on 35 :scream:

1 Like

Thank you for the information! Hopefully this will be fixed soon, especially since multiple people have confirmed it. Good luck with regular Silverblue, by the way. It’s a wonderful OS. :slight_smile:

1 Like

I rebased two days ago to kinoite/KDE and there were missing openvpn und NetworkManager-openvpn, but the problem is even after installing them - connecting to a vpn through the GUI still does not work. Maybe I’m missing something else?

My current workaround is installing only openvpn and using eOVPN (flatpak) for GUI.
Before rebasing I had saved and connected to VPN from the networkmanager applets of gnome, so those two package were definitely integrated into the silverblue image. Can we get them integrated as well into the kinoite image? :slight_smile:

Thanks in advance!

You need plasma-nm-openvpn (which should add all dependencies). I’m considering including it as part of the image to make this simpler.

I know it must be stated somewhere in this long thread.

Would you please advice what is the remote refs that can be used to rebase from a Silverblue deployment to Kinoite latest?

Thank you so much, it works now. Definitely should be included as part of the image. After all it’s a part of the desktop environment’s functionality. That’s why it’s of course included in gnome’s Silverblue image.

Can i ask, where do the packages from the base image of Kinoite come from? Do they share the same source as the ones I have installed from fedora’s repos with rpm-ostree install? Since I have layered them now, could I run into incompatibility problems during upgrades?

I’m still trying to wrap my head around the Silverblue/ostree system, which i find it’s fantastic!

The summary is in Current status of Fedora Kinoite. See the Fedora Magazine article for the commands: Discover Fedora Kinoite: a Silverblue variant with the KDE Plasma desktop - Fedora Magazine. You’ll have to replace 33 by 34 to get the latest.


Kinoite (and all the other variants) are 100% built from untouched Fedora RPM packages so there is no risk of incompatibility. The only difference is that my unofficial builds are signed by my personal OpenPGP key and not Fedora’s one.

Indeed, I will probably add that in the next builds. Thanks

Strictly theoretically speaking - when i have those packages layered, what will happen in my case in the future, when you introduce those same packages in an upcoming upgrade of the base kinoite image?

Should i remove them beforehand or?

1 Like

Hey Timothée, I would be very interested in such a (probably updated?) package list, or is it somehow possible to get the needed from the “dnf groupinstall kde-desktop-environment” command. Are these the same packages I need for the sudo rpm-ostree install command or are the packages different?

1 Like

You can easily generate an updated list with the linked script. Just clone the workstation-ostree-config repo, switch to the f34 branch, copy the script there and run it.

The generated lists are a subset of those packages, essentially removing all non critical applications.

1 Like

OK, but I get a 404.
EDIT: I have it now. Thanks a lot!!!

Thank you very much!

I rebased to kinoite and it loads beautifully.

One observation:

When running rpm-ostree ostree under Silerblue 34 or 35, OstreeRemoteStatus for kinoite is unknown.

        OstreeRemoteStatus: Remote "kinoite" not found
                   Version: Kinoite 34.20210517.0 (2021-05-17T12:30:04Z)
                BaseCommit: 5fd0c525b4959b5088aff1fefa33d0b1432da2a168621511f72f98c69fbefde6
           LayeredPackages: qemu-img smartmontools
                    Pinned: yes

If booting Kinoite and run rpm-ostree status, then all is normal.

Ah, I’ve forgotten a feedback from my side: I tried KDE, XFCE, Gnome, LXQt, Mate and Pantheon. All loaded perfectly fine. I needed to take away some packages but the terminal listed them, so this was easily done. Unfortunately, I did not have the opportunity to continue testing because I made a mistake and relabelled the file-system.


This could be a bug in rpm-ostree. Could you report that upstream Issues · coreos/rpm-ostree · GitHub? Thanks!


Fedora Kinoite is now available in the official mirror for the Rawhide branch! :tada:

Please move all new discussions related to Fedora Kinoite only to the new Kinoite category in the forum!

As I will now focus a lot more on fixing Fedora Kinoite specific issues, I will stop building unofficial Rawhide branches soon. I will keep building stable & branched versions for the other variants but can not promise doing that longer than one or two release cycles.

Feel free to reach out if you’re interested in taking over or maintaining a specific variant.

Thanks for the support and testing during all those years!


What kind of details I should collect and post?

What you’ve posted here plus the list of ostree remotes you have should be a good starting point. We will ask for more in the ticket if needed.

1 Like