Kernel 6.2.7 and 6.2.8 on fedora 37 can't boot on Thinkpad X220 with Soft Lock error

hello, I’m facing problem with the kernel version 6.2.7 and 6.2.8 on Fedora 37, after the update, when I tried to boot via those kernel, I got stuck, soft lock error on kernel. I already tried to reinstall, and check the journalctl -b 1 and journalctl -b 2, but seems because it’s failed, and the kernel is facing soft locked, it can’t even reach the journalctl.

Is there anyway to check why this is happening? I really hope My Thinkpad X220 with i7-2640m kept working beyond 2030… If possible with fedora… and newest kernel.

Thank you

1 Like

same issue on Thinkpad T14 2gen (intel i7) ; I’m stuck with this version: 6.0.7-301.fc37.x86_64; so all my upgrades excludes any kernel package!

1 Like

I report it on bugzilla, but I can’t do anything as it can’t even boot

1 Like

I just get the solution, in short you can add intremap=off to the cmdline of the kernel and enable AHCI, it fix the issue, and I can boot. The culprit is i915 intel gpu kernel mod

More detail see 2182684 – Kernel Stable 6.2.7 and 6.2.8 Can't boot on X220 Thinkpad with Soft Lock
and see Fixing Booting Problem with Kernel 6.2.x on Fedora with Thinkpad X220 – Benyamin Limanto

Hope this help!


In my case, it works installing the nvidia private driver, cause the noveau Driver not work correctly.