KeePassXC browser integration


thanks this looks very safe and higher security. although following the instructions carefully you sent I keep getting the error attched in the above message

I assume you went through all the points from KeePassXC: Getting Started Guide Double check all steps.
So you’ve successfully connected add-on with KeePassXC and saved database with add-on keys, but later can’t connect?

Is either KeePassXC or browser installed from flatpak?

1 Like

I installed the flatpak version. And I installed the plugin, Yes i followed the instructions very carefully…

Is there a chance my browser is blocking it?

1 Like

Flatpak’s sandbox might be blocking the connection, backup your database (and key file, if you used it) and use fedora’s package:

flatpak remove org.keepassxc.KeePassXC
dnf install keepassxc

thanks for your help.

I followed that command and installed the fedora version…

It still has the same issue


I hope this is right. I wish I knew why it wont connect.

I just tested it on Fedora KDE 34 Wayland with Brave installed from Brave’s repo - works fine.
Try connecting to database again, go to KeePassXC-Browser settings → Connected databases, remove all connections to databases and click on Connect to configure it again.

1 Like

Thanks for your efforts, I went to the connected datbases and there is nothing there listed.

I am running cinammon with Brave perhaps it because of that>?

I tried uninstalling the plugin and reinstalling. Perhaps I need a different plugin

I doubt Cinnamon blocks anything, I just successfully tested it in VM. Unlock database in KeePassXC, restart Brave and press Connect in plugin’s settings - a window should pop-up to configure the connection.

1 Like

Okay done, thanks a lot,.

Good news now I get a different mesage:



This is great,

it also tells me this now:

So I will update it and hopefully its all done?


Is there an easy way to import all my passwords ?

You must have omitted some steps from KeePassXC guide before, I’m glad that now it’s working.

I imported passwords long time ago through KeePass - it has many import add-ons and KeePassXC imports old and opens new KeePass databases.
Fedora 34+ has latest KeePassXC version, so you might want to upgrade to it (instead of installing the website version).


thanks very much for your assistance. Should I import the passwords by exporting the passwords from the browser, or is there an easier way

So when I type sudo dnf update how come it doesn’t update the package if we installed KeepassXC through dnf ?

1 Like

You’re welcome. KeePassXC can import CSV exported form browser, but if you manage to import passwords directly from browser (I don’t know if KeePass will import from Brave), that should support also some additional attributes, it’s worth trying.

What’s the output of that command?
dnf -C list installed keepassxc


Great I’ll Try to do that. This is way better security I feel than trusting the browser.

So basically the browser Will be locked now from all my passwords by KeepassXC. I will export the passwords from Brave then import them to the program keepassxc. Then I can delete all my saved passwords in Brave.

I’ll read the literiture on the program (keepass) to see how it works, hopefully i can put a two factor authenticator on it somehow to really lock it down tight.

[benji@localhost ~]$ dnf -C list installed keepassxc

Installed Packages
keepassxc.x86_64                      2.6.4-2.fc33                      @updates
[benji@localhost ~]$ 

You’re running Fedora 33.

Hi there,

Great thanks a lot. Can you also tell me how I can import the passwords from Brave as when I do it asks me to create another database and that database doesn’t seem to sync with the browser.

You can either:

  • drag and drop entries form one database to the other,
  • connect new database with browser (in add-on settings).

This is great help thanks again, I’l be okay okay from here,

It looks very powerful with the various degrees of encryption strength and different encryption protocols. Your right, its better to keep passwords out of the cloud and out of the browser, makes sense now.

1 Like

Glad I could help you. Make sure you don’t forget the password, without it there’s no way to access database.

Mark as solution answer that solved your main issue.