KDE plasma session crashing launching firefox through KDE

I’m having this incredibly odd issue with my machine. If I try to launch Firefox from the task manager or the search it will just crash my KDE session. Launching it from the terminal works just fine however, and it’s how I’m using Firefox right now.

This happened after an issue (with probably Mesa) that caused my display to hard lock up during gaming. I’ve been having some really nasty issues relating to display stuff for some reason, anyways, I had to hard power off the machine as it was completely unresponsive to any keyboard inputs, I couldn’t even get into tty through ctrl+alt+f3. It’s not the first time I’ve had a display driver crash hard lock up my system, in fact, it’s happened quite a few times because of Mesa’s issues with H265 for a while and SteamVR.

I’d REALLY like not to have to reinstall as setting up my desktop on KDE doesn’t have any way to save presets between computers, which REALLY sucks and means I have to do EVERYTHING from scratch regarding my desktop widgets and task manager setup.

edit: I was able to reproduce the crash in dolphin by running the application file used by KDE inside of it, running it in the terminal I get the following output

ibpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
QString::arg: 2 argument(s) missing in firefox
dbus[16047]: arguments to dbus_message_new_method_call() were incorrect, assertion "destination == NULL || _dbus_check_is_valid_bus_name (destination)" failed in file ../../dbus/dbus-message.c line 1375.
This is normally a bug in some application using the D-Bus library.

  D-Bus not built with -rdynamic so unable to print a backtrace
KCrash: Application 'dolphin' crashing...
The Wayland connection experienced a fatal error: Bad file descriptor
1 Like

I’ve had the same problem today. I’ve also found other people have it too and theres a couple of workarounds. ill link them for you.




I have the same problem, the second link from @honeygiant had the solution for me (seems like you have to downgrade firefox for now). Here is the command if someone just wants the solution: sudo dnf downgrade firefox-118.0


I found this too, but my fix was to install the firefox-wayland and thunderbird-wayland wrapper packages, then I pointed those icons “Firefox on Wayland” and “Thunderbird on Wayland” to the KDE task manager instead of the generic firefox and thunderbird.

Launching those do not crash the plasma. This way you can keep using the latest Firefox and Thunderbird. I did this on Fedora 39 Beta.

I think it’s probably wrong for firefox-wayland and firefox-x11 packages to contain their own copies of /usr/share/applications/firefox-wayland.desktop and /usr/share/applications/firefox-x11.desktop respectively. Those packages already require ‘firefox’ which carries both those desktop files.

Not a KDE user (this month), but after reading both links above in hoping to find a solution to graphics glitches in Gnome, I wanted to offer a second opinion on the safest solution.

In the first link above, @kjoonlee points to the second link above and suggests:

Comment out line 54 (DBusActivatable=true) from /usr/share/applications/firefox.desktop file.

Further down @adamwill adds:

I would strongly recommend you use the workaround suggested by @kjoonlee, do not downgrade Firefox. This version is a critical security update.

YMMV but since you are reading this in my future, please do your review of all links above (and maybe below, I don’t know) for new facts as they unfold after I press Reply here. Good luck and stay safe!

(Off-topic, probably, but it’s concurrent and crashy and happens opening Firefox or Chromium: I seem to have fixed my own AMD graphics issues (screen shattering into wonky triangles, but never actually crashes) in Gnome by becoming a beta tester of F39. During that process the upgrader noted that 3 packages (VLC from rpmfusion, Firefox, and Chromium) all wanted different versions of ffmpeg. So I uninstalled VLC and disabled RPM Fusion, tried again and completed my upgrade to F39 beta. All is working well so far, but I can’t say what One Thing did it in my case. I haven’t re-installed VLC yet, figured I’d wait until F39 is final before fiddling with anything again.)

After modifying firefox.desktop, KDE may not have cached the modified version. This occurred to me when I performed rpm-ostree rollback, and the application launcher continued to use the defective desktop file. To force KDE desktop to immediately rebuild the system configuration cache, run kbuildsycoca5.

Same issue here on Kinoite after updating to latest commit, which included a ton of KDE-related packages. Firefox can’t be started anymore, which is pretty annoying. I literally just went and rebased to Silverblue because of the lack of QA with KDE packages — I did upgrade my Kinoite chasing another KDE bug, and the resulting borked Firefox was the straw that broke the camel’s back.

Are KDE packages not tested before being pushed to stable?

firefox including those .desktop files was an accidental change which is being reverted.

This was a Firefox update. There’s an automated test suite, but the test ran on Workstation, so it didn’t catch the issue. None of the testers who gave feedback were using KDE either, apparently.