Issues with Telegram Desktop app with F38 - extremely slow to start

Testing F38 Beta and noticed that the Telegram Desktop app is extremely slow to start when running KDE Plasma Wayland. Additionally, the icon doesn’t display in the system tray for an even longer period of time, but after about 15 minutes or so it finally appears. Has anyone else seen this behavior? Doesn’t happen with F37.

It is the Flatpak app right?

No, actually I’m just using the tsetup file from here.

RPM fusion free has also a package for the app. Did you try this?

Available Packages
Name         : telegram-desktop
Version      : 4.6.5
Release      : 1.fc37
Architecture : x86_64
Size         : 31 M
Source       : telegram-desktop-4.6.5-1.fc37.src.rpm
Repository   : rpmfusion-free-updates

Configuration - RPM Fusion

Yep, I’ve tried it. It does the same thing. Looking for someone else to replicate before I issue a bug report.

1 Like

I will just first i need to upgrade to test. I was planing to do this today too.

1 Like

Great, thanks! Yeah, eventually Telegram will start and be responsive and functional, but it takes about 15 minutes (at least on my old laptop). Only happens on wayland, X11 it seems fine. The system tray will show a blank (empty) space for where the icon should show. Eventually, the screen does a refresh and the icon appears. As I mentioned, on F37 it works fine.

I do have a KDE-plasma VM where i test.

Have you checked the env variable and made a grep to see what it outputs fro telegram?
To compare with F37.

No I haven’t. I’m travelling and don’t have access to my F37 machine right now.

I have the same issue with a recent upgraded Fedora 38 and Telegram. Did you use nvidia too?

removing that package (or upgrading from the latest kodi build) seems to fix the issue.

1 Like

Thanks for the link. I tried to remove the package, but of course you really can’t’ or shouldn’t:
dnf remove xdg-desktop-portal-gnome
Problem: The operation would result in removing the following protected packages: gnome-shell

Yes dnf resolves dependencies.

You can try this if you just want to remove :

rpm -e xdg-desktop-portal-gnome

sudo rpm -e xdg-desktop-portal-gnome
error: Failed dependencies:
xdg-desktop-portal-gnome is needed by (installed) gnome-shell-44.0-4.fc38.x86_64

yeah, you need --nodeps to do that, but then what happens to my wayland gnome applications that need xdg-desktop?

Thanks for that link. What a mess… :frowning:

So we have the practice of Fedora installing GNOME by default for Fedora workstation and then if you install KDE Plasma and try to use Wayland, it breaks…

Having two big DE on the same Fedora installation is usually considered an unsuported configuration. Anyway, upgrading the package to the latest koji build seems also to fix the bug

you’ll probably have to run dnf upgrade

This upgrades will probably land soon on the stable repo so just waiting for them should suffice anyway :stuck_out_tongue:

Thanks! I’ve got the testing repos enabled, so will wait for the changes to be pushed there. Not sure why they haven’t been already. As far as two big DEs not being supported, not sure where you got that idea. In fact, it’s been almost impossible to add another desktop to Fedora Workstation for years since GNOME is so entrenched with it. KDE is a supported SPIN.