Issues with Linux Kernel 6.7.3 and 6.7.4

Is anyone else experiencing strnage behavior with these kernels. All of the issues I am having occur after undocking, or attempting to shutdown while docked. The most noticeable symptom has been that the wireless adapter on my laptop is not detected after a hardwired connection. So if I boot up without being docked the behavior is normal. Once I connect to a dock, the hardwired connection takes over and everything works normally. Go to shutdown…nope. Disconnect, and the nothing works in the GUI you have to perform a hard reset…i.e. hold the power button down until it turns off.

Rolling back using 6.6.14 fixes everything. I tried the 6.7.4 kernel from testing to see if the behavior is the same, and it is. Any information would be helpful. Will dig into it deeper later when I have real time to tear it apart.

Do you have any Bug reports? It would be good to file these with bugzilla since you’ve deduced the kernel issue right away.

1 Like

Not yet. I hope to have time this week to dig into it.

Yes, I’ve been having issues with Wi-Fi with the 6.7.x kernels. It seems to be related to changing frequencies. I found a report at [REGRESSION] 6.7 broke wifi "AP is in CSA process, reject auth". I’ve filed a bug at 2263192 – Wi-Fi connection problems with AC 9260 and 6.7 kernels.

Atheros hardware is unaffected.


I am also having problems with 6.7. I have an older HP laptop with a second external monitor attached. When I boot into it, the laptop starts displaying the boot screen but flickers. Then it does blank and only the external monitor displays anything. ARandR shows only the external monitor is accessible. The graphics card info is:

Vendor: NVIDIA
UMD Version: Mesa 23.3.5
Model: GK107GLM (Quardo K1100M)

It’s using the nouveau driver, as the card’s too old for the NVIDIA ones.

Booting to the 6.6.4 kernel works fine.

1 Like

Added the following bug 2263340 – Linux Kernel 6.7.3 Following A Hardwired Connection Wireless Adapter Intel Wi-Fi 6 AX210/AX211/AX411 is Missing

According to nvidia the Quadro K1100M is supported by the nvidia drivers version either 390xx or 470xx. Both of those are available from the rpmfusion-nonfree repo for installation on fedora 39 (or F38).

I don’t know if they work properly on the 6.7.X kernels though.
I do know that those driver versions only support using the xorg desktop since neither are able to support wayland.

1 Like

My computer blocks after 5-10 minutes in Fedora 39 and kernel 6.7.3. When I use 6.6.13, my computer runs perfectly
12th Gen Intel Core i7-12700 @ 20x 4.8GHz
GPU: Mesa Intel(R) UHD Graphics 770 (ADL-S GT1)
My keyboard is completely blocked (Razer Hundsman Elite with RGB; RGB is out). Also RGB from mouse is also down. I see some activity in screen but I loose all capacity to control computer

With some assistance at least on my part this appears to be caused by using TLP kind of a must have on a laptop since TuneD and PPD are kind of a hot mess as far as using them withr event based triggers, and for fine tuning behavior with peripherals. Anyway apparently something changed in the kernel and the following options break things:

# Radio devices to disable on connect.


# Radio devices to enable on disconnect.


Whereas the following options still work:

# Radio devices to enable/disable when docked.


# Radio devices to enable/disable when undocked.


Switching to the DOCK options, which I have found in the past to not be as reliable in enforcing what is on or off has resolved this issue for me. I still plan on digging into the issue, and opening a bug with the TLP devs to see if there is a fix planned, or if in fact something in the kernel is not working the way it should. Hope this helps some others here since the issues seem to be mostly with laptop users from what I have observed I think the TLP issue caused by recent kernel changes/regressions may be a common thread.

I still use, but every variation/configuration I’ve tried using the drivers from rpmfusion-nonfree just hoses my system. The nouveau driver works fine, though. I’m not doing anything that’s graphic intensive.

I also have problems with 6.7.3 and my external monitor. All the output goes to the built-in monitor, not the Thunderbolt 4 connected external monitor. And I see only top left part of the image. If I set the settings to Mirror, no problems. Only Join is problematic.

I do not have a dedicated GPU, so I’m running the one in my Intel i7-1165G7. I use Wayland session on my up to date Fedora 39. Switching back to 6.6.14 fixes the problem.

FWIW, just “upgraded” to 6.7.4 and the problem is still there.

After upgrading to the new kernel, my laptop (Lenovo Yoga 7 Pro 14ARP8) is not able to resume from suspend. I’ve tried updating the BIOS but the problem still remains.

mem-sleep is showing [s2idle] btw

Please start a new thread with a title like “Lenovo Yoga 7 Pro 14ARP8 fails to resume from suspend on kernel 6.7.4” so it is easier for others with the same hardware to find it. Laptop power management often breaks with new Linux kernels. Linux and Windows differ in their approaches to power management. Particularly for devices (display, network, keyboard, pointing) that are enabled at boot, you are at the mercy of the vendor for BIOS and firmware updates. Workarounds are sometimes posted on other linux distro or vendor forums.

Did you mean: cat /sys/power/mem_sleep shows [s2idle]?

In my case, the built-in screen is no longer detected and therefore turned off.

It’s a Sony Vaio VPCF13M1E Laptop (CPU: Intel i5 M 560, GPU: NVIDIA GeForce GT 425M, built-in screen: 1080p @ 59.94 Hz). There are no proprietary drivers installed.

If I switch back to Kernel 6.6.14, everything works fine. On the two never versions it turned out, that I can still connect an external display, but the laptop will behave like a desktop computer and won’t show any built-in screen in the screen settings.

The built-in screen supports 1920 x 1080 @ 59.94 Hz while the external (usually disconnected) screen supports 60 Hz. If I set the external screen to the same frequency (59.94 Hz) and reboot, the switch happens after the login and there’s still no built-in screen available.

That’s exactly my situation, David. The only difference is I have an HP zBook. Whenever the kernel is upgraded, I need to uninstall the previous 6.7.x version so that 6.6.14 won’t cycle out.

Fedora does not (ever) remove the currently booted kernel, though things may become out of sync with everything else being updated.

You can manually uninstall that kernel or you can allow fedora to follow the default behavior which is to remove the oldest and not currently running kernel when installing a new kernel.

Is the external display set as primary? If so it may result in this behavior. I seriously doubt that it is no longer detected, but rather that some config is wrong which causes this.

Initially investigate the display settings within the settings → display panel to verify how things are configured. Simplest would be to set the displays both as mirrored to see if they both remain active, then tweak it if you choose a different arrangement.

Please note that with some nvidia GPUs it has been discovered that nouveau does not properly support 2 displays and that installing the nvidia drivers from rpmfusion has fixed that for several users.

I just upgraded to 6.7.4 and the issue still persists. This time around, I did it in the evening, in the dark and I noticed my built-in display is blank, but the backlight is on, with the image still showing only the top left portion, on the external display.

I’m having a very similar problem on my Fedora 39 system. I have a 2013 vintage laptop with a Nvidia “GeForce GTX 670MX” GPU. I don’t need anything fancy from it, so I use the Nouveau driver. It stopped working [edit: I should have said ‘started running the software video driver at low resolution’] with the 6.7.3 update, but works perfectly if I boot into 6.6.13.

I’m happy to file a bug report, but I wonder if there’s particular info that I should try to gather for a Noveau vs. Nvidia vs. kernel issue like this?