Suspected Kernel / Modules Regresion -- Unsure Where to Fill the Issue

I can reproduce an issue I am having with my external display, connected through a thunderbolt 3 dock to my laptop (a Framework 13, intel 13th gen). The issue happens when I boot the latest kernel (6.4.13-200.fc38.x86_64), but the issue doesn’t happen in the previous one (6.4.12-200.fc38.x86_64), and hence it may be a regression in the kernel or some modules (video, thunderbolt,… IDK).

Before entering in the details, please note that my question is where to open an issue (here? Kernel? Kernel who --Fedora’s kernel team, Linus’ team / module maintainers?) and, based on your experience, what data do i need to submit for the submission to be taken in consideration effectively. And, of course, where to look to to check whether this issue has already been filled.

The issue I am having is that with the latest batch of updates.

  • if I boot in the latest kernel the external display gets blank and suspends itself after 3 seconds of displaying the desktop.
  • However, the laptop still senses that there may be something receiving a signal, as the display set up doesn’t fall back to a situation where all applications are represented in the integrated display --it sends them “into the void”.
  • As I said, booting in the previous kernel gets me a smooth and stable connection with the external display
  • This happens regardless I switch to External Only, Laptop Only, Mirrored or Extended display setup.

So: who do I reach out with more data about this? :slight_smile: Thanks!

First, you should upgrade the system. I upgraded 2 days ago and today received another 60+ packages to upgrade, including kernel 6.4.14. Maybe your problem has already been solved, but you will not know unless you do the upgrade and reboot for the newer kernel.

Second, you never told us anything about what graphics you have. GPU drivers may be involved in the issue and not just the kernel.

The proper site to report bugs for all things fedora is Red Hat Bugzilla Main Page

Thanks. For whatever reason I haven’t received yet a new kernel (tried a few hours ago).

For completeness, the GPU is the Intel integrated one (no discrete GPU).

I’ll wait for a newer kernel and if this persists will go to the linked bugzilla.

You may try the upgrade with new metadata using dnf upgrade --refresh which forces a reread of the metadata from the repos at the beginning of the upgrade process. That should give you the newer kernel to install.