Issues with Linux Kernel 6.7.3 and 6.7.4

Btw some Intel Laptops fail to to boot on 6.7x and rawhide 6.8x when using the karg debugfs=false

I submitted a bug report: 2263967 – Older NVidia card comes up in VGA mode under 6.7.3/4, but works fine under 6.6.13.

I don’t see anything like that in my GRUB screen if I type ‘e’. My only change to the default is I added ‘acpi_backlight=video’, and removing that has no effect on the problem.

My problem was resolved. It was caused by a bad driver configuration, which was left over from months ago when I tried the proprietary NVidia drivers. Why the kernel change triggered the bug I have no idea, but fixing the configuration allows me to run correctly. The details are in the bug report I linked to earlier.

Hmm, apparently my bug is different. I downloaded Fedora Rawhide to test with the 6.8 RC3 kernel, and the problem still exists. So this has nothing to do with my setup, it is reproducible even on a live CD. Interestingly enough, it is only when using the Thunderbolt → DP adapter - if I plug in the monitor directly to the HDMI port of my laptop, everything works as expected.

This makes it seem directly related to the adapter itself and not to fedora or the kernel.

Yeah, but the adapter is working fine with the 6.6.14, so it is related to the kernel in some way. Where do you suggest opening a bug (sorry, this will be my first)?

1 Like

I would guess related to the Thunderbolt driver maybe, so something for Thunderbolt upstream?

Thank you very much for your replies. My problem has been resolved by installing the proprietary NVIDIA drivers (which also resulted in switching to X11).
Things i’ve tried:

  1. Setting the display configuration to mirrored: It behaves exactly the same, when I boot under the never kernel version. After the flashing _ (underscore), the display turns off (no backlight), external display still works (if connected)
  2. Downloading the latest rawhide release (Version 20240215) and creating a live USB-stick: Same result
  3. Enabling the non-free RPM fusion repository and installing the proprietary NVIDIA driver (in my case the packages “xorg-x11-drv-nvidia-390xx” and “akmod-nvidia-390xx”): Display flickers sometimes before showing the login screen and afterwards. It switches back to X11 (since it’s a legacy driver). But all that matters for my use case: Once the startup is completed, it works perfectly again.

Important notice: I have been using Wayland since the initial installation (Fedora 30) and never had any problems until now on this specific laptop.

Those drivers do not support wayland at all. If your GPU is of the vintage that requires those older drivers then you must use xorg when using the nvidia drivers.

Please provide the output of lspci -nnk | grep -iA3 vga so we can confirm if that is the proper driver for the installed nvidia GPU.

1 Like

It shows the following:

VGA compatible controller [0300]: NVIDIA Corporation GF108M [GeForce GT 425M] [10de:0df0] (rev a1)
Subsystem: Sony Corporation Device [104d:907a]
Kernel driver in use: nvidia
Kernel modules: nouveau, nvidia_drm, nvidia

As I wanted to do some other experiment, I uninstalled it temporarily (using dnf history) to give the nouveau driver another try. It did not (yet) go back to wayland and the display behaves exactly the same under the X11 session:
LVDS-1 disconnected
VGA-1 disconnected
HDMI-1 connected primary

So in my case it’s just a nouveau driver under old graphics card thing.

The GeForce GT 425M chip seems supported by the nvidia 390xx drivers from rpmfusion and nothing newer. This means that if you use the nvidia drivers you would need to install it using sudo dnf install akmod-nvidia-390xx and then would be limited to using xorg only as the DE.

The flip side is that if you use nouveau and wayland then you have no hardware acceleration with the GPU and the CPU will be tasked with all graphics rendering.

It is your choice which way you wish to proceed.

1 Like

Thank you.
I reinstalled the nvidia 390xx driver and keep it that way.

I use an old iMac that only has Nvidia. I run nouveau+wayland until something doesn’t work, then switch to nvidia+Xorg. Once you have the rpmforge nvidia drivers working, it isn’t a lot of work to adjust the kernel command-line and reboot.